Need change to abouthealth.css to work around lack of flexbox support

VERIFIED FIXED

Status

()

Firefox
General
--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: laura, Assigned: mconnor)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox21+ verified)

Details

(Whiteboard: [fixed in beta])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
(As discussed in IRC, getting a bug on file.)

Turns out that as well as the server-side piece depending on flexbox (bug 858264), the chrome also depends on flexbox.  Since this did not ship in 21.0 beta, we need to work around it.

Schalk has a solution.  The contents of abouthealth.css should change to:
--
* {
  margin: 0;
  padding: 0;
}

html, body {
  background-color: rgb(250, 250, 250);
  height: 99%;
}

#remote-report {
  width: 100%;
  height: 100%;
  border: 0;
} 
--

Until this lands (hopefully in the next beta), about:healthreport will have a double scrollbar.

mconnor, can you test and land it please?
QA Contact: anthony.s.hughes
(Assignee)

Comment 1

5 years ago
Created attachment 733933 [details] [diff] [review]
workaround for flexbox being disabled

tested on a local beta build, eliminates the double scrollbar.
Attachment #733933 - Flags: review?(gavin.sharp)
Under what circumstances does the double scrollbar appear? I have yet to reproduce this bug.
(Reporter)

Comment 3

5 years ago
ashughes: If the content needs a scrollbar - try looking at the Raw Data tab.
(In reply to Laura Thomson :laura from comment #3)
> ashughes: If the content needs a scrollbar - try looking at the Raw Data tab.

Thanks Laura, I can see this bug now.
Comment on attachment 733933 [details] [diff] [review]
workaround for flexbox being disabled

rs=me, but I really wish we'd revisit this styling with someone who knows how to actually make this work right.
Attachment #733933 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 6

5 years ago
Comment on attachment 733933 [details] [diff] [review]
workaround for flexbox being disabled

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 841873 happened and MDN was in a confusing state way back when.
User impact if declined: Double scrollbar on about:healthreport
Testing completed (on m-c, etc.): locally verified on beta. will have QA verify after landing.
Risk to taking this patch (and alternatives if risky): minimal to none, no risk outside of about:healthreport
String or IDL/UUID changes made by this patch: none
Attachment #733933 - Flags: approval-mozilla-beta?
Attachment #733933 - Flags: approval-mozilla-aurora?
Comment on attachment 733933 [details] [diff] [review]
workaround for flexbox being disabled

Approving on beta, helps avoid the double scrollbar issue for FHR reports in about:healthreport.
Attachment #733933 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to Mike Connor [:mconnor] from comment #6)
> Comment on attachment 733933 [details] [diff] [review]
> workaround for flexbox being disabled
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): 841873 happened and MDN was in a
> confusing state way back when.
> User impact if declined: Double scrollbar on about:healthreport
> Testing completed (on m-c, etc.): locally verified on beta. will have QA
> verify after landing.
> Risk to taking this patch (and alternatives if risky): minimal to none, no
> risk outside of about:healthreport
> String or IDL/UUID changes made by this patch: none

mconnor, Bug 841876 - Re-enable flexbox pref (by default) in release builds  should be enabled on aurora. Is this the bug we need to avoid the Flexbox issue ?

If its enabled per Bug 841876 on Fx22, would this patch still be needed there ?
(In reply to Mike Connor [:mconnor] from comment #6)
> Comment on attachment 733933 [details] [diff] [review]
> workaround for flexbox being disabled
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): 841873 happened and MDN was in a
> confusing state way back when.
> User impact if declined: Double scrollbar on about:healthreport
> Testing completed (on m-c, etc.): locally verified on beta. will have QA
> verify after landing.
> Risk to taking this patch (and alternatives if risky): minimal to none, no
> risk outside of about:healthreport
> String or IDL/UUID changes made by this patch: none

Please make sure to land before/by Monday morning as we are targeting go-to-build early PT Monday morning.Thanks !
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/2c2a5fce2c7b

Can't set the correct flags, but this is fixed on beta, I'll land on trunk tomorrow.
Whiteboard: [fixed in beta]

Updated

5 years ago
Component: Client: Desktop → General
Product: Firefox Health Report → Firefox

Updated

5 years ago
status-firefox21: --- → fixed
(Assignee)

Comment 11

5 years ago
Assuming bug 841876 sticks, we're done here.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 841876
Resolution: --- → FIXED

Updated

5 years ago
tracking-firefox21: --- → +

Updated

5 years ago
Attachment #733933 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 12

5 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0

Reproduced this issue with Firefox 21 beta 1 (Build ID: 20130401192816) based on comment 3.

Verified as fixed on Firefox 21 beta 2 (Build ID: 20130408165307). No double scrollbar in about:healthreport.
Status: RESOLVED → VERIFIED
status-firefox21: fixed → verified
actually, setting the approval back to a nomination for Aurora (not clear if this is the permanent solution). ni on mconnor for comment 8.
Flags: needinfo?(mconnor)

Updated

5 years ago
Attachment #733933 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora?
Comment on attachment 733933 [details] [diff] [review]
workaround for flexbox being disabled

As Flexbox will be enabled in Fx22 this patch is no longer needed on aurora.
Attachment #733933 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora-
(Assignee)

Comment 15

5 years ago
Yes, as long as flexbox stays enabled, this needs no further action.
Flags: needinfo?(mconnor)
You need to log in before you can comment on or make changes to this bug.