Closed Bug 858323 Opened 7 years ago Closed 7 years ago

Selection is black if content isn't focused when selection starts

Categories

(Firefox for Android :: Text Selection, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

When we were using a fake mouse event to start selection, a side effect was that it would focus the content where the selection is happening. Because that's no longer the case, we should do something to make sure the content window is focused when starting a selection.
I found the issue here is that the browser element wasn't focused. Instead of trying to focus it whenever text selection starts, I decided to focus it when we set the selected tab.
Assignee: nobody → margaret.leibovic
Attachment #738190 - Flags: review?(wjohnston)
Comment on attachment 738190 [details] [diff] [review]
Focus tab.browser when the tab is selected

Review of attachment 738190 [details] [diff] [review]:
-----------------------------------------------------------------

Maybe add a comment explaining why we need this.
Attachment #738190 - Flags: review?(wjohnston) → review+
https://hg.mozilla.org/mozilla-central/rev/bb1cb21e711c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 738190 [details] [diff] [review]
Focus tab.browser when the tab is selected

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 854605
User impact if declined: text selection will be black unless the user taps on the content to focus it first
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low-risk, focuses browser when selected instead of when a user taps on the content
String or IDL/UUID changes made by this patch: n/a
Attachment #738190 - Flags: approval-mozilla-aurora?
Attachment #738190 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.