Rendering error on B2G keyboard

RESOLVED DUPLICATE of bug 826152

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 826152
5 years ago
3 years ago

People

(Reporter: jld, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 733701 [details]
Screenshot of the bug in action

The conditions: B2G (reproduced with "emulator" and "unagi" configurations), with the line "background: url(images/key-shadow.png) no-repeat center -1px;" deleted from gaia/apps/keyboard/style/keyboard.css.  (The background-size line next to it can be deleted or not; it doesn't seem to matter.)  Do something that wants text entry (e.g., start the "UI tests" app, choose "Keyboard test", and select a text field) and type on the soft keyboard.

What happens: when touching/clicking any key on the first two rows (the ones where the popup that shows the pressed key extends outside the bounds of the keyboard and overlaps the running app; this may be relevant), other keys get a gradient repeatedly painted over them.  Anything which causes a repaint restores the keys to their original appearance over the affected area.

What should happen: Not that.  I don't know the gaia keyboard app well, but as far as I'm aware there shouldn't be anything in the DOM corresponding to the gradients that are drawn.

How to not reproduce (i.e., workaround, and possibly useful info about what might be going on): replace the background line with "background-image: none;" instead of removing it.

Sorry I don't have a less B2G-specific repro for this.

Gecko is ee7a204c8 from git.mozilla.org/releases/gecko.git (gecko-18 branch); gaia is 5b9aafa38 (v1-train branch).
(Reporter)

Comment 1

5 years ago
I wonder if this is related to bug 826152.
(Reporter)

Comment 2

5 years ago
Given bug 826152 comment #17, I'm going to go out on a limb and call this a duplicate.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 826152
You need to log in before you can comment on or make changes to this bug.