Passwords prompt mentions browser name, not app

RESOLVED WORKSFORME

Status

()

Firefox for Android
Web Apps
P2
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

21 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [A4A])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
"Twitter" just asked me if Aurora should save my password. Adding insult to injury, because of course it would not fill in my password, despite Aurora knowing it, and form filling it a minute before.
Definitely awkward for recognizing you are in an app context, but not terribly impacting.

I'll go with P2 A4A on this one.
Priority: -- → P2
Whiteboard: [A4A]
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854940
Not a dupe.

Richard, I am having a hard time finding the place where "Aurora" is used in that prompt.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 737001 [details]
Password prompt (in browser)

Nothing about "Nightly" though. Is the prompt different?
Created attachment 737003 [details]
Pasword prompt (in WebRT)

Same as browser.
FWIW, we should probably check the packaged app case to make sure the app:// doesn't appear.
(Reporter)

Comment 7

5 years ago
Created attachment 737139 [details]
Related issue

The original case no longer occurs. The dialog was something like "Do you want Aurora to remember your password on twitter.com?". Might still repro on Beta, but don't have it installed to check. It now reads something like "Remember this password on twitter.com?". 

str as simple as: add twitter webapp, sign in to Web app, observe doorhanger. 

Note that chrome error pages are still wrong; see attachment. But that's a separate bug. 

(Bugzilla from Fennec; sorry for incompleteness)
Right. I'd open a new bug for the issue in that screenshot. That's involving the cert error page, which is a different bug than this.

Given that the original bug filed here is now working, closing as wfm.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.