Closed Bug 858433 Opened 7 years ago Closed 7 years ago

web page not displayed properly in Firefox20 and 21beta.

Categories

(Core :: Internationalization, defect)

20 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
firefox20 --- affected
firefox21 + verified
firefox22 --- unaffected
firefox23 --- unaffected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: jp-critical, regression)

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/releases/mozilla-beta/rev/2e91ff229d84
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 ID:20130401192816


Steps To Reproduce:
1. In "View > Character Encoding", Set auto-detect Japanese/Universal, if necessary
2. Open http://www.tbs.co.jp/anime/k-on/

Actual Results:
Background is black.

Expected Results:
Background image should be drawn.


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/4dfe323a663d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210134422
Bad:
http://hg.mozilla.org/mozilla-central/rev/87f8165c5a0b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121211 Firefox/20.0 ID:20121211075159
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4dfe323a663d&tochange=87f8165c5a0b

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/21d667b49f3a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210060651
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a4c6ce2b95a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121210 Firefox/20.0 ID:20121210061551
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=21d667b49f3a&tochange=a4c6ce2b95a1

Regressed by:Bug 638379


Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/519c7cf5605b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130312 Firefox/22.0 ID:20130312013135
Good:
http://hg.mozilla.org/mozilla-central/rev/79b8e0a0bdb7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130312 Firefox/22.0 ID:20130312123538
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=519c7cf5605b&tochange=79b8e0a0bdb7

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8948998650e1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130311 Firefox/22.0 ID:20130311190036
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/8d7a31fbb879
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130311 Firefox/22.0 ID:20130311190337
Fixed Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8948998650e1&tochange=8d7a31fbb879

Fixed by: 
 8d7a31fbb879	Josh Aas Bug 843434: Fix assert in nsUnicharStreamLoader. r=emk



Please uplift the Bug 843434 to 21.0Beta.
And this page http://www.tbs.co.jp/anime/oregairu/staffcast/
same regression range. Bug 843434 fixed.
Summary: web page not displayed properly. → web page not displayed properly in Firefox20 and 21beta.
Depends on: 843434
Do we have any more reports or information on if any other Japanese sites are impacted or is the reported site the only one that is broken ?
Can someone verify if this is no longer reproducible now that bug 843434 is landed and in beta 2 - ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/21.0b2-candidates/build1/
(In reply to lsblakk@mozilla.com from comment #3)
> Can someone verify if this is no longer reproducible now that bug 843434 is
> landed and in beta 2 -
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/21.0b2-candidates/
> build1/


I cannot reproduce the problem on 21.0b2-candidates build with attachment 733749 [details].
http://hg.mozilla.org/releases/mozilla-beta/rev/c4dfe07f855c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 ID:20130408165307

Thanks for quick fix.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
It is known what bug fixed this.
Resolution: WORKSFORME → FIXED
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

Verified as fixed on Firefox21 Beta2(Build ID:20130408165307).
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

Verified as fixed on Firefox21 Beta2(Build ID:20130408165307).
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130419 Firefox/23.0

Verified as fixed on Firefox latest nightly (Build ID:20130419030957).
I confirm it is fixed on FF 21b6. Based on this and on Comment 6 and Comment 7 -> Verified Fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.