Address bar not visible when modifying layout.css.devpixelsperpx

RESOLVED WORKSFORME

Status

()

Core
Widget
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: harjoc, Unassigned)

Tracking

({regression})

20 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 733759 [details]
screenshot 1

Steps:
- Updated to firefox 20.0 on ubuntu 12.04.1. 
- Created new profile (using firefox -P).
- Modified layout.css.devpixelsperpx to 1.1.

Result:
Address bar suggestions (history urls), file/edit/... menu popups, search box now are all shown incompletely (see screenshots):
- address bar doesn't show history, only a tiny stub, same for search box
- menu popups look like they don't have enough space to display all items

All of these were working fine on firefox 19.0. I've tested on 2 machines with ubuntu 12.04.1, one of which is a fresh install.

Apparently there are minor issues on windows as well: on windows 7, firefox 20, changing layout.css.devpixelsperpx makes a solid black band show instead of the gradient shadow behind the address bar.
(Reporter)

Comment 1

5 years ago
Created attachment 733760 [details]
screenshot 2
(Reporter)

Comment 2

5 years ago
Created attachment 733761 [details]
screenshot 3

Updated

5 years ago
Keywords: qawanted, regressionwindow-wanted

Comment 3

5 years ago
(In reply to harjoc from comment #0)
> Apparently there are minor issues on windows as well: on windows 7, firefox
> 20, changing layout.css.devpixelsperpx makes a solid black band show instead
> of the gradient shadow behind the address bar.

You're right, I observe that with Firefox 23 on Win 7.
In addition, when you're typing something in the location bar, the drop-down menu is opening gradually from top to bottom with a large blank area at the end with missing URL entries.

Regression range:
m-c
good=2013-02-26
bad=2013-02-27
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=73f0c5b00572&tochange=e7632ab657e5

Comment 4

5 years ago
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/739f20de3c1e
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121207 Firefox/20.0 ID:20121207030741
Bad:
http://hg.mozilla.org/mozilla-central/rev/b7fab17d30b7
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121208 Firefox/20.0 ID:20121208030937
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=739f20de3c1e&tochange=b7fab17d30b7

Triggered by:
	ac48e5c365e2	Jonathan Kew — bug 814434 - use global display pixels for window positioning/sizing for consistency across mixed-resolution screens. r=smichaud
Blocks: 814434
Status: UNCONFIRMED → NEW
Component: Menus → Widget
Ever confirmed: true
Keywords: regressionwindow-wanted → regression
Product: Firefox → Core
I'm pretty sure this will turn out to be the same as bug 840881.

There are currently several things that are a bit broken if you change devPixelsPerPx - the workaround is to leave it untouched! On Windows, at least, it should no longer be needed to scale things properly for hi-dpi displays.
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20130728 Firefox/25.0

I am unable to reproduce this on Firefox 23 beta 9 (buildID: 20130725195523) or latest Nightly (buildID: 20130728030204). Probably was fixed along with bug 840881.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

5 years ago
Seems fixed here as well on firefox 21 - ubuntu standard package (I'm the initial reporter). 

Thanks.
You need to log in before you can comment on or make changes to this bug.