pdf extension not appended

RESOLVED DUPLICATE of bug 221028

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 221028
5 years ago
5 years ago

People

(Reporter: Todd, Unassigned)

Tracking

19 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

FF 19.0.2 for Linux 64 bit

http://www.elpolloloco.com/contentAsset/raw-data/865b8079-86ee-4266-8f60-a37c85270ab6/fileAsset/fe71ceeb-9867-4eec-b356-d23ebda41c18?force_download=1&filename=EPL%20Web%20Nutrition%20Guide%20Mod%203.pdf

1) this downloads instead of opening in Firefox's new inline pdf viewer

2) when downloaded, the pdf extension in left off.  (Adding .pdf to the name and you can open it with both Acrobat Reader and Firefox's new inline reader.)
via http://web-sniffer.net

Content-Disposition:	attachment; filename=EPL Web Nutrition Guide Mod 3.pdf

The "attachment" part forces a download dialog instead of the inline pdf viewer and the not escaped spaces in the filename explain the cut-off extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 221028
You need to log in before you can comment on or make changes to this bug.