Inheritance from elements with display:table-cell broken

VERIFIED FIXED

Status

()

Core
CSS Parsing and Computation
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: dbaron)

Tracking

(4 keywords)

Trunk
css2, testcase, verified1.8.0.12, verified1.8.1.4
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Hixie-P3][sc-frame-relationship][A2], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The 'content' property doesn't inherit from a cell to it's ':after' pseudo-
element. This works fine for other elements.

Testcase: http://www.hixie.ch/tests/adhoc/css/inheritance/content/002.xml
(Reporter)

Updated

16 years ago
Keywords: css2, mozilla1.0, testcase
Whiteboard: [Hixie-P3]

Comment 1

16 years ago
You should have included the build id of the version you saw this on.

This bug does occur on build 2001060712 on Macintosh.

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 2

15 years ago
Setting All/All per comment #1.
OS: Windows 2000 → All
Hardware: PC → All
(Assignee)

Comment 3

15 years ago
Are there other inheritance problems in the same place?
Created attachment 122420 [details]
Testcase showing border inheritance problem too
So... The problem is that table cells have this block frame inside... and this
block frame is what's used as the parent frame when ProcessChildren() is called
from ConstructTableCellFrame().  So the pseudo style context of that block is
what's used as the parent style context for the <td>'s kids.
Assignee: hyatt → dbaron
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0.1 → ---
Summary: 'content' property doesn't inherit in tables [GC] [CASCADE] → Inheritance from elements with display:table-cell broken
(Assignee)

Comment 6

14 years ago
Yet another bug resulting from the backwards relationship between style contexts
and frames.
Whiteboard: [Hixie-P3] → [Hixie-P3][sc-frame-relationship]
(Reporter)

Updated

12 years ago
Whiteboard: [Hixie-P3][sc-frame-relationship] → [Hixie-P3][sc-frame-relationship][A2]
(Assignee)

Updated

12 years ago
Blocks: 289480
(Assignee)

Updated

12 years ago
No longer blocks: 289480
Depends on: 291854
Blocks: 289517
(Assignee)

Comment 7

12 years ago
I think Boris just fixed this for the dynamic case in bug 289517 but not for the static case.
(Assignee)

Comment 8

12 years ago
Actually, I backed that part of the patch out.  (And I'm actually not 100% sure it's right, although the difference is irrelevant unless somebody styles ::-moz-cell-content.)

Updated

12 years ago
Blocks: 323656

Comment 9

12 years ago
I filed bug 323656 as table cells are not the only case when this happens
No longer blocks: 323656
Depends on: 323656
Fixed by checkin for bug 323656.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
I don't see any :after tests in attachment 261617 [details] [diff] [review], so this testcase isn't quite redundant with tests in there and thus should be committed, correct?
Flags: in-testsuite?
I suppose.  I didn't want to commit these tests as-is, because they would break if we implement the proposed CSS3 generated content stuff.  I suppose we could add explicit tests that :before and :after inherit from their parent; I should write some like that.
Though that's going to take weeks, at least; if someone gets to it before me I'll be very very happy.
Verified fixed on trunk and branches.
Both testcase (url and attached one) now show "PASSED" at the places where it is expected.
Status: RESOLVED → VERIFIED
Keywords: verified1.8.0.12, verified1.8.1.4
You need to log in before you can comment on or make changes to this bug.