Closed Bug 858773 Opened 8 years ago Closed 8 years ago

crash in nsPluginInstanceOwner::CallSetWindow @ nsObjectFrame::CallSetWindow

Categories

(Core :: Plug-ins, defect)

22 Branch
All
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 854082
Tracking Status
firefox21 --- unaffected
firefox22 --- affected
firefox23 --- affected

People

(Reporter: scoobidiver, Assigned: johns)

References

Details

(Keywords: crash, regression)

Crash Data

It first showed up in 22.0a1/20130321. The regression range might be:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8156df33b757&tochange=1d6fe70c79c5

Signature 	nsObjectFrame::CallSetWindow(bool) More Reports Search
UUID	e322e881-486b-4929-b91b-4a10f2130405
Date Processed	2013-04-05 01:22:58
Uptime	119
Last Crash	4.3 days before submission
Install Age	1.4 hours since version was first installed.
Install Time	2013-04-04 23:59:26
Product	Firefox
Version	23.0a1
Build ID	20130404030859
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x40c0001c
App Notes 	
AdapterVendorID: 0x8086, AdapterDeviceID: 0x0126, AdapterSubsysID: 04ba1028, AdapterDriverVersion: 9.17.10.2932
Has dual GPUs. GPU #2: AdapterVendorID2: 0x10de, AdapterDeviceID2: 0x0dd1, AdapterSubsysID2: 0000000c, AdapterDriverVersion2: 9.18.13.1409D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	sp-processor02.phx1.mozilla.com_17868:2008
EMCheckCompatibility	True
Adapter Vendor ID	0x8086
Adapter Device ID	0x0126
Total Virtual Memory	4294836224
Available Virtual Memory	3496587264
System Memory Use Percentage	53
Available Page File	11252649984
Available Physical Memory	3982008320

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsObjectFrame::CallSetWindow 	layout/generic/nsObjectFrame.cpp:687
1 	xul.dll 	nsPluginInstanceOwner::CallSetWindow 	dom/plugins/base/nsPluginInstanceOwner.cpp:3360
2 	xul.dll 	nsPluginHost::InstantiatePluginInstance 	dom/plugins/base/nsPluginHost.cpp:958
3 	xul.dll 	nsObjectLoadingContent::InstantiatePluginInstance 	content/base/src/nsObjectLoadingContent.cpp:765
4 	xul.dll 	nsObjectLoadingContent::SyncStartPluginInstance 	content/base/src/nsObjectLoadingContent.cpp:2403
5 	xul.dll 	nsObjectLoadingContent::ScriptRequestPluginInstance 	content/base/src/nsObjectLoadingContent.cpp:2376
6 	xul.dll 	nsObjectLoadingContent::DoNewResolve 	content/base/src/nsObjectLoadingContent.cpp:2979
7 	xul.dll 	mozilla::dom::HTMLObjectElementBinding::_newResolve 	obj-firefox/dom/bindings/HTMLObjectElementBinding.cpp:2148
8 	mozjs.dll 	js::GetPropertyOperation 	js/src/jsinterpinlines.h:295
9 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:2243
10 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:357
11 	mozjs.dll 	js::InvokeKernel 	js/src/jsinterp.cpp:422
12 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:455
13 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:5854
14 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1433
15 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:578
16 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:85
17 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:112
18 	xul.dll 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1003
19 	xul.dll 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:328
20 		@0x25f152c0 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsObjectFrame%3A%3ACallSetWindow%28bool%29
Very likely another regression from 784131, given the date. Possibly dupe of bug 854082 / bug 856262
Assignee: nobody → jschoenick
Blocks: 784131
Status: NEW → ASSIGNED
See Also: → 856262, 854082
(In reply to John Schoenick [:johns] from comment #1)
> Possibly dupe of bug 854082 / bug 856262
There have been no crashes since 23.0a1/20130425 and 22.0a2/20130425 that matches bug 854082's patch landing.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854082
See Also: 856262
You need to log in before you can comment on or make changes to this bug.