Hitting 'back' in my.yahoo.com brings up login page

VERIFIED WORKSFORME

Status

()

Core
Document Navigation
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: mozbug1, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

When I click a link on my my yahoo page and hit 'back' the login page shows up
in my browser window instead of my my yahoo page.

Reproducible: Always
Steps to Reproduce:
1. Go to my.yahoo.com
2. Click on the sign in link on the upper right.
3. Click on 'secure'
4. Sign in
5. Click on a news artcle
6. Press the back button

Actual Results:  The login page that you first see on going to my.yahoo.com
shows up.

Expected Results:  The my yahoo page showing my news articles should show up

I just listed the steps I use to log in, I suspect even a straight login would
do the same thing.

After I hit back and the login page is there, if I just click on the location
bar and hit enter the correct page shows up.

Updated

17 years ago
Assignee: gordon → radha
Component: Networking: Cache → History: Session
QA Contact: tever → claudius

Comment 1

17 years ago
Sounds more like a session history problem.

Comment 2

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001062804


Marking nEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't reproduce this  in the RTM release. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
VERIFIED WFM with 2001081003 Win98 build
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
This is still a reproducible bug.
I am using Mozilla 0.9.9 on Win2000 and I can reproduce it every single time,
not just on my.yahoo.com, but also on other secure login sites.
I wonder if this is related to bug#114897, as it sounds similar.  I don't know
if the fix for that bug made it to 0.9.9 release or not...
Please assure that this is fixed - its a very annoying problem that I run into
daily.
Thank you.

I think it is bug 114897 that you are seeing. That bug probably didn't make it
to  0.9.9

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.