Variables view closes immediately on first open

RESOLVED FIXED in Firefox 23

Status

P1
normal
RESOLVED FIXED
6 years ago
5 months ago

People

(Reporter: jryans, Assigned: vporof)

Tracking

Trunk
Firefox 23

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Using the tip of fx-team (rev 5e01908df6d7).

STR:

1. Open the Debugger
2. Click the button to open the variables view
3. It will open and close immediately
4. Click the button again
5. It will stay open this time
(Assignee)

Comment 1

6 years ago
I'm not able to reproduce this. Is this happening on a certain page? I tested with http://htmlpad.org/debugger/ and it seems to be working properly.

What OS are you on?
(Reporter)

Comment 2

6 years ago
I am using OS X 10.8.3, and it happens for me on that page.

But then I just realized it doesn't happen with a clean profile.  It looks like the issue is I have "Show panes on startup" checked in the Debugger options.  When the Debugger first opens, the button to toggle panes thinks the panes are already opened, but the variables view is not shown.  So, the first click goes back to closed mode (after a brief flash of open), and then the next click actually opens it.

Disabling this option gets rid of the issue, so it seems like the real problem is that the "Show panes..." setting is not being respected properly.
(Assignee)

Comment 3

6 years ago
(In reply to J. Ryan Stinnett [:jryans] from comment #2)
> Disabling this option gets rid of the issue, so it seems like the real
> problem is that the "Show panes..." setting is not being respected properly.

Aaah!
(Assignee)

Comment 4

6 years ago
Created attachment 734634 [details] [diff] [review]
v1

Obviously...
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #734634 - Flags: review?(rcampbell)
Comment on attachment 734634 [details] [diff] [review]
v1

Review of attachment 734634 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/shared/widgets/ViewHelpers.jsm
@@ +113,5 @@
> +
> +    // Add a class to the pane to handle min-widths, margins and animations.
> +    if (!aPane.classList.contains("generic-toggled-side-pane")) {
> +      aPane.classList.add("generic-toggled-side-pane");
> +    }

obviously.
Attachment #734634 - Flags: review?(rcampbell) → review+
(Assignee)

Updated

6 years ago
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/2e2ae594b1ac
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 23

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.