Enable high-quality image scaler in every case.

RESOLVED DUPLICATE of bug 795072

Status

()

defect
RESOLVED DUPLICATE of bug 795072
6 years ago
5 years ago

People

(Reporter: blind_box2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130407 Firefox/23.0
Build ID: 20130407030841

Steps to reproduce:

I visited this site.

https://bug486918.bugzilla.mozilla.org/attachment.cgi?id=657754


Actual results:

The high-quality image scaler is not working.


Expected results:

The scaler should have worked. Right click > view image > zoom out by itself works.
(Reporter)

Updated

6 years ago
Depends on: 486918
OS: Windows 7 → All
Hardware: x86 → All
Version: Trunk → unspecified
(Reporter)

Comment 1

6 years ago
I did a few more testing and realized this bug might be related to https://bugzilla.mozilla.org/show_bug.cgi?id=795072 .

Having only a single picture to downscale, as shown in this attachment, makes the HQ scaler work. Having two pictures in an HTML for downscaling, makes the HQ scaler fail.
(Reporter)

Updated

6 years ago
Attachment #734541 - Attachment mime type: text/plain → text/html
(Reporter)

Updated

6 years ago
Depends on: 795072
Component: DOM: Core & HTML → ImageLib
(Reporter)

Comment 2

6 years ago
(Reporter)

Updated

6 years ago
Attachment #734541 - Attachment description: single image scaling → image scaling working with one image
(Reporter)

Updated

6 years ago
Attachment #735023 - Attachment mime type: text/plain → text/html

Comment 3

6 years ago
Note sure if this is the correct bug, but let me add another example:

GOOD: https://github.com/joyent/node/commits/master
BAD: https://github.com/silverwind/Droppy/commits

Github uses downscaled avatar images here, and it seems that if one image appears a certain amount of times, the downscaler doesn't kick in at all for it. In case node's commit log doesnt show smooth downscaling, view any other commit log with many different authors.

Comment 4

6 years ago
In the link here https://bugzilla.mozilla.org/show_bug.cgi?id=486918#c289 (beware, excessive memory-usage!)
some images are scaled, some are not.
So just having more than one image doesn't break the scaling.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 795072, 486918
Resolution: --- → DUPLICATE
Duplicate of bug: 795072
You need to log in before you can comment on or make changes to this bug.