File slave bugs automatically for known failure cases

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: coop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [automation][capacity][slaveapi])

(Reporter)

Description

6 years ago
When we reach the end of certain code paths in kittenherder, we *know* that the next step is filing a bug to recover the slave, e.g. a talos-r3 machine is unpingable.

There's no sense in waiting for a human to notice that. kittenherder (or replacement) should file that bug (and do the associated dance with the appropriate reboots bug) automatically.

catlee already has some code to do this:

https://github.com/catlee/relengbot/blob/master/relengbot/slave_bugger.py

Comment 1

6 years ago
For some reason this bug is marked as a goal.
"[ON TRACK] better slave issue tracking bug 859403"
(Reporter)

Comment 2

6 years ago
(In reply to Armen Zambrano G. [:armenzg] (Release Enginerring) from comment #1)
> For some reason this bug is marked as a goal.
> "[ON TRACK] better slave issue tracking bug 859403"

It's marked as a goal because it's pretty important, and we all agreed to it at the start of the quarter.
(Reporter)

Updated

6 years ago
Depends on: 878049
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Comment 3

5 years ago
slaveapi does this now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [automation][capacity] → [automation][capacity][slaveapi]
(Reporter)

Updated

5 years ago
Duplicate of this bug: 897792
(Assignee)

Updated

2 years ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.