Closed Bug 859425 Opened 7 years ago Closed 7 years ago

Move decoding/storing favicons to background thread

Categories

(Firefox for Android :: Awesomescreen, defect)

15 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 23
Tracking Status
firefox20 + fixed
firefox21 + fixed
firefox22 + fixed
firefox23 --- fixed

People

(Reporter: mfinkle, Assigned: mfinkle)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
The awesomescreen will load favicons in a separate, lazy task. However the Cursor holding the favicons is handed back to the UI thread where we loop over the data, decode bitmaps and store in the Favicon mem cache.

We should be doing that in the background thread. This patch moves the function call to the background thread.
Attachment #734729 - Flags: review?(bugmail.mozilla)
Attachment #734729 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/5549afae23a7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 734729 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: DB code on the UI thread can cause ANR hangs and locks. Plus we are decoding bitmaps on the UI thread instead of the background thread.
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low risk. straight forward change
String or IDL/UUID changes made by this patch: none
Attachment #734729 - Flags: approval-mozilla-beta?
Attachment #734729 - Flags: approval-mozilla-aurora?
Assignee: nobody → mark.finkle
Comment on attachment 734729 [details] [diff] [review]
patch

low risk patch with stability win. Approving for beta/aurora .
Attachment #734729 - Flags: approval-mozilla-beta?
Attachment #734729 - Flags: approval-mozilla-beta+
Attachment #734729 - Flags: approval-mozilla-aurora?
Attachment #734729 - Flags: approval-mozilla-aurora+
Comment on attachment 734729 [details] [diff] [review]
patch

[Triage Comment]
We're going to take this low risk, stability win for our 20.0.1 mobile respin
Attachment #734729 - Flags: approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.