Closed Bug 859434 Opened 10 years ago Closed 10 years ago

Close thumbnail cursor in TopSitesView

Categories

(Firefox for Android Graveyard :: General, defect)

15 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(firefox21+ fixed, firefox22+ fixed)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox21 + fixed
firefox22 + fixed

People

(Reporter: mfinkle, Assigned: mfinkle)

Details

Attachments

(1 file)

Attached patch patchSplinter Review
We never close the cursor used to load and decode a thumbnail bitmap in TopSitesView.java
Attachment #734740 - Flags: review?(lucasr.at.mozilla)
Attachment #734740 - Flags: review?(lucasr.at.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/78457232611a
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 734740 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Not closing cursors can lead to crashes like bug 760394
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low risk. simple patch
String or IDL/UUID changes made by this patch: none
Attachment #734740 - Flags: approval-mozilla-beta?
Attachment #734740 - Flags: approval-mozilla-aurora?
Comment on attachment 734740 [details] [diff] [review]
patch

Low risk patch which can help with Bug 760394 , a DB related top-crasher.
Attachment #734740 - Flags: approval-mozilla-beta?
Attachment #734740 - Flags: approval-mozilla-beta+
Attachment #734740 - Flags: approval-mozilla-aurora?
Attachment #734740 - Flags: approval-mozilla-aurora+
Assignee: nobody → mark.finkle
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.