Right-click popup slow (>0.5sec) on this page (a really big form)

VERIFIED DUPLICATE of bug 77073

Status

()

Core
XUL
P3
minor
VERIFIED DUPLICATE of bug 77073
17 years ago
10 years ago

People

(Reporter: Ken Harris, Assigned: Blake Ross)

Tracking

({perf})

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nav+perf], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1+) Gecko/20010611
BuildID:    2001061108

On this page, http://www.timezoneconverter.com/cgi-bin/tzref.tzc
(which is a really big form), the right-click popup menu is
significantly slower than any other page I've seen -- maybe half
a second on my Athlon-900, 256MB.

Reproducible: Always
Steps to Reproduce:
1. Go to this page
2. Right-click on an empty area

Actual Results:  Popup menu appears after 0.5sec.

Expected Results:  Popup menu should appear faster -- like it does on other pages.

See also bug 77051, Linux popup menus painfully slow.

But the popup menu on other pages isn't nearly this slow,
and the popup menu on this page in 4.x is instantaneous, so
I don't think it's just Linux.

With 0.9.1 on Windows 2000, it's slower than other pages,
but not this slow.

I realize I'm using the word "slow" a lot.  I don't know how to
get some solid numbers; maybe somebody could help me out?  :-)
i think this is a dupe of something morse fixed this past week.
Assignee: pinkerton → morse
(Reporter)

Comment 2

17 years ago
Ach so!  I tried 2001061411, and it's much better.  That's
what I get for running a browser that's 3 days old.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
I don't see much of difference between either 6/11 or 6/14 on linux. It is 
slower on that page and it gets slower as I add more elements to the form, 
I assume due to the form management code being triggered. Always room for 
optimization, although I don't find this pathologically slow.

Comment 4

17 years ago
I haven't investigated this, but I could well believe that it is the form 
manager.  I do a walk through the dom in order to determine which entries I want 
to make visible in the context menu.  If this ain't broke (not pathologically 
slow), then let's not fix it.
(Assignee)

Comment 5

17 years ago
The slowdown is pretty noticeable for me, and it's only going to get worse on
slower machines and pages with more form elements, so I think it's worth looking
into how to improve this.
Status: RESOLVED → UNCONFIRMED
Keywords: perf
Resolution: INVALID → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
nav triage team:

Yes, it would be nice for this to be faster, but not a 0.9.3 stopper. Marking
nsbeta1+, p3, and mozilla1.0
Keywords: nsbeta1+
Priority: -- → P3
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 7

17 years ago
--> me
Assignee: morse → blake
Whiteboard: [nav+perf]
(Assignee)

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 77073 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
I can dig it.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.