Closed Bug 859532 Opened 7 years ago Closed 7 years ago

[B2G][Settings][Bluetooth] Unable to spool a second file, while first file is transferring via Bluetooth

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 817972

People

(Reporter: ndavidson, Unassigned)

Details

Attachments

(1 file)

Attached image Error message
Description:
User is unable to spool a second file, while first file is transferring via Bluetooth. User is getting “Bluetooth transfer failed” error while transfer is in a progress.

Repro Steps:
1) Updated to Unagi Build ID: 20130404070202
2) Have at least 1 min video on a device
3) Go to Settings >Bluetooth
4) Enable Bluetooth and make it visible to all
5) Rename your device differently from default name and tap “OK” button.
6) Tap on "Search for devices" button
7) Connect to a found device by confirming PIN number
8) Go to the Gallery app and select a video file
9) Tap on "Share" button and select Bluetooth transfer
10) Tap OK button to confirm
11) User receives a notification about file transfer on the receiving device and accepts the file transfer
12) While file transfer is in progress, send a picture from a gallery via Bluetooth to the same user

Actual:  User is getting an error - “Bluetooth transfer failed. Check that the Bluetooth settings are correct.”

Expected: User file would be put in spool queue and send as soon as first file  transfered

Environmental Variables:
Unagi Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/da523063aa7b
Gaia: a845be046c5d3cb077e3c78f963ca5c079e7ab3d

Notes:
Repro frequency:  100%,
Test Suite Name: Bluetooth
See attached screenshot
This is a dup of bug 817972. Currently we don't supported having more than one file-transfer session at a time.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 817972
Adding additional description to bug 817972
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.