Closed Bug 859551 Opened 7 years ago Closed 7 years ago

Work - Don't thumbnail capture when in snapped view

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P2)

x86_64
Windows 8
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ally, Assigned: ally)

References

Details

(Whiteboard: feature=work)

Attachments

(1 file, 1 obsolete file)

currently we snapshot sites even when they are in snapped view, which can result in ugly half pictures on your start page. 

I think perhaps we should check the os view state in our shouldCapture function
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=0
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=0 → feature=defect c=tbd u=tbd p=0
Summary: don't thumbnail capture when in snapped view → Defect - Don't thumbnail capture when in snapped view
Attached patch functional, but magic numbers (obsolete) — Splinter Review
- issues with access to metro utils in desktop mode, and what might be an access issue in immersive mode if you snap immediately (which I am weirded out by).
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=2
Attachment #736990 - Attachment is obsolete: true
Attachment #737051 - Flags: review?(rsilveira)
Blocks: metrov1it6
No longer blocks: metrov1defect&change
Hi Ally, what story (Bug ID) is this defect related to?
Status: NEW → ASSIGNED
Flags: needinfo?(ally)
Priority: -- → P1
QA Contact: jbecerra
Comment on attachment 737051 [details] [diff] [review]
better, workaround

Review of attachment 737051 [details] [diff] [review]:
-----------------------------------------------------------------

looks good.
Attachment #737051 - Flags: review?(rsilveira) → review+
Marco, I think 831919, on the grounds that new stories/features should not regress older/finished ones.
Flags: needinfo?(ally)
Blocks: 831919
No longer blocks: metrov1it6
Priority: P1 → P2
Summary: Defect - Don't thumbnail capture when in snapped view → Work - Don't thumbnail capture when in snapped view
Whiteboard: feature=defect c=tbd u=tbd p=2 → feature=work
...this is in today's m-c, but there's no merge comment?
I dropped the '1' from the end of my bug comment. 

https://hg.mozilla.org/mozilla-central/rev/d9a88189be9c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.