Last Comment Bug 859586 - Remove {Start,End,Fail}DocumentLoad notifications
: Remove {Start,End,Fail}DocumentLoad notifications
Status: RESOLVED FIXED
[e10s]
: addon-compat, dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Extension Compatibility (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 23
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks: fxe10s
  Show dependency treegraph
 
Reported: 2013-04-08 17:46 PDT by Bill McCloskey (:billm)
Modified: 2013-08-05 11:43 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.14 KB, patch)
2013-04-08 17:46 PDT, Bill McCloskey (:billm)
felipc: review+
Details | Diff | Review

Description Bill McCloskey (:billm) 2013-04-08 17:46:24 PDT
Created attachment 734920 [details] [diff] [review]
patch

These aren't used within firefox. Felipe says that the addons that use them are no longer up-to-date. Also, the interface is weird because it only notifies you if the load happens in the foreground tab.
Comment 1 :Felipe Gomes (needinfo me!) [offline until Jun 24] 2013-04-08 17:54:50 PDT
Comment on attachment 734920 [details] [diff] [review]
patch

as endDocumentLoad is gone, let's rename startDocumentLoad to something better (clearCurrentPageData maybe?) and remove the aRequest unused parameter (but don't remove it from the if condition that calls the function)
Comment 2 Jorge Villalobos [:jorgev] 2013-04-09 14:28:37 PDT
I see at least a couple of active add-ons that still use these notifications. That shouldn't stop you from fixing this, and I also agree that it's an odd API that has better alternatives.
Comment 3 Bill McCloskey (:billm) 2013-04-13 11:35:19 PDT
I did a search for amo addons that include the string |DocumentLoad"| (without the bars). I filtered out addons where maxversion was below FF4. I also filtered out Thunderbird addons, since I'm assuming that Thunderbird doesn't use code from browser.js (maybe I'm wrong?). I found only two addons:

https://addons.mozilla.org/en-us/firefox/addon/dom-inspector-6622/
I'm guessing this is now mostly used by SeaMonkey since Firefox already has a built-in DOM inspector. Does SeaMonkey use browser.js from Firefox?

https://addons.mozilla.org/en-us/firefox/addon/html-validator/
Looks like people still use it, although it was last updated for FF9.

If nobody objects, I'm going to land this with Felipe's changes as well as a comment requested by Gavin.
Comment 5 Ryan VanderMeulen [:RyanVM] 2013-04-16 06:22:07 PDT
https://hg.mozilla.org/mozilla-central/rev/76ba09dd8b7b
Comment 6 Sylvain Giroux 2013-07-25 08:17:29 PDT
As a follow up. Not all xpi are getting distributed via addons.mozilla.org.

I can confirm that hundreds of our addons were using EndDocumentLoad and this change breaks certain features in our framework.

We created a fix and we currently are rolling updates for our most important customers.

We found out the exact cause of this problem thanks to Jorge Villalobos and his post on 2013/07/24. https://blog.mozilla.org/addons/2013/07/24/compatibility-for-firefox-23/

Note You need to log in before you can comment on or make changes to this bug.