file open dialog buttons not working

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tenisthenewnine, Assigned: mounir)

Tracking

({regression})

22 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox21 unaffected, firefox22+ verified, firefox23+ verified)

Details

(Whiteboard: [fixed by bug 52500])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Hi team,

On http://convertfiles.com/ clicking the browse button doesn't open up a file upload box - it used to work until recently and it works fine in IE.

I can replicate this on windows 7 and windows 8.

Thanks

Comment 1

6 years ago
The upload box sometimes appears when clicking on the text box for the file name (especially after changing the radio buttons), but I have not been able to get the upload box to appear by clicking on the Browse... button with Nightly 23.

The text box is not part of the upload native upload mechanism, but another text box placed over it.

The Browse... button works with Firefox 20.0 and Chrome.
I am pretty sure this was broken by the new <input type=file>.
Flags: needinfo?(mounir)
Confirming setting to new:

win7 x64
cset: Nightly build - http://hg.mozilla.org/mozilla-central/rev/b0d842380959
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130408 Firefox/23.0
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Depends on: input[type=file]

Comment 4

6 years ago
m-c
good=2013-03-27
bad=2013-03-28
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=178a4a770bb1&tochange=962f5293f87f

The issue is with the new rendering of <input type='file'> and probably some CSS styles which are not well positionned anymore.

The website applies 'opacity: 0.0' to the input to hide the native 'browse' button which is replaced by a 'browse' image (GIF).
But now, as the rendering of <input type='file'> is shorter in width, the positionned 'browse' image doesn't fit anymore with the hidden input.
No longer depends on: input[type=file]

Comment 5

6 years ago
Posted file Reduced testcase
Just play with 'opacity' from 0.0 to 1.0 to see the difference with the width on <input type="text">

Updated

6 years ago
Depends on: input[type=file]

Comment 6

6 years ago
Last Good: efa7756f90a4
First Bad: 511ea736284e

Triggered by:
511ea736284e	Mounir Lamouri — Bug 345195 - Replace the anonymous <input type='text'> in <input type='file'> by a xul:label. r=bz

Updated

6 years ago
Version: 23 Branch → 22 Branch
(Assignee)

Comment 7

6 years ago
I believe this should be fixed by bug 253690. Unfortunately the tests in the patch in bug 253690 need some fixing on MacOS X and I do not have time to fix that for the moment.
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Component: Untriaged → Layout: Form Controls
Flags: needinfo?(mounir)
OS: Windows 8 → All
Product: Firefox → Core
Hardware: x86_64 → All

Updated

6 years ago
Duplicate of this bug: 861002

Updated

6 years ago
Duplicate of this bug: 873743

Comment 10

6 years ago
It seems to be fixed in Nightly, maybe by bug 52500.
(Assignee)

Comment 11

6 years ago
(In reply to Loic from comment #10)
> It seems to be fixed in Nightly, maybe by bug 52500.

Yes. I copy/paste'd the wrong bug number in comment 7.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 52500]
Verified as fixed on Firefox 22 beta 4 - file open dialog button is working:
Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID:20130605070403
Simona, can you please verify if this is fixed with Firefox 23?
Keywords: qawanted
Verified as fixed on Firefox 23.0a2:
Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130618 Firefox/23.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:23.0) Gecko/20130618 Firefox/23.0
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130618 Firefox/23.0
Build ID: 20130618004018
QA Contact: simona.marcu
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.