No event when remote peer disappeared

RESOLVED DUPLICATE of bug 852665

Status

()

defect
RESOLVED DUPLICATE of bug 852665
6 years ago
5 years ago

People

(Reporter: luczo.laszlo.86, Unassigned)

Tracking

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC][blocking-webrtc-][spec-issue])

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130408 Firefox/23.0
Build ID: 20130408030928

Steps to reproduce:

Start https://apprtc.appspot.com demo app and connect with two client.
Block incoming and outgoing connections in the first client towards to the second one.


Actual results:

Remote videos were freezing but time counter didn't stop counting.
No event was raised when peer disconnected.


Expected results:

oniceconnectionstatechange event fired and iceconnectionstate changed to disconnected.
Reporter

Updated

6 years ago
Component: Untriaged → WebRTC
Product: Firefox → Core
We haven't implemented oniceconnectionstatechange and iceconnectionstate yet, so that's probably the first problem here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [WebRTC][blocking-webrtc-][spec-issue]

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 852665
You need to log in before you can comment on or make changes to this bug.