If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add dictionary for Estonian, including dictionary license addition to about:license

VERIFIED FIXED in Firefox 22

Status

()

Toolkit
General
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Pike, Assigned: gerv)

Tracking

unspecified
mozilla23
Points:
---

Firefox Tracking Flags

(firefox21+ wontfix, firefox22+ fixed, firefox23+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
We'd like to add a dictionary for Estonian, but http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/file/bf9bd258ccd2/extensions/spellcheck/hunspell/README_et.txt asks for an addition to about:license.

Gerv, can you do a patch for that?

Right now, we're asked to add it to beta, thus flagging this up to Firefox 21.

Sander, I'll need to reject the sign-off with the dictionary until we have the about:license blurb in place.
Looks like we need help from gerv as per Axel's comment above, hence passing it on.

Please make sure to get this ready before beta 3(Apr 16)/beta 4 goes to build.
Assignee: nobody → gerv
tracking-firefox21: ? → +
tracking-firefox22: ? → +
tracking-firefox23: ? → +
(In reply to Axel Hecht [:Pike] from comment #0)
> We'd like to add a dictionary for Estonian, but
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/file/bf9bd258ccd2/
> extensions/spellcheck/hunspell/README_et.txt asks for an addition to
> about:license.
> 
> Gerv, can you do a patch for that?
> 
> Right now, we're asked to add it to beta, thus flagging this up to Firefox
> 21.
> 
> Sander, I'll need to reject the sign-off with the dictionary until we have
> the about:license blurb in place.

Axel we are assuming your sign-off's will cover QA testing .If there is anything additional needed on client side please make sure to CC & let :ashughes for help

Comment 3

5 years ago
Ping..
(Assignee)

Comment 4

5 years ago
Created attachment 738406 [details] [diff] [review]
about:license Patch v.1

Here's the about:license patch. Sorry for the delay - I've been rather busy. So if someone else can drive this to checkin, that would be awesome.

Gerv
Pike, Sander : what are the next steps here ? In terms of timeline Fx21 beta 4 is going to build tomorrow ~noon PT and this would be the last opportunity for low risk speculative fixes .

Updated

5 years ago
Flags: needinfo?(l10n)

Comment 6

5 years ago
I really don't know. Axel?
(Reporter)

Comment 7

5 years ago
Bhavana, Gerv summarized the steps really well, this needs someone to drive the patch.

I don't think this can make 21 still, thus marking 21wontfix.
status-firefox21: affected → wontfix
Flags: needinfo?(l10n)
(Assignee)

Comment 8

5 years ago
The about:license patch can be checked straight in. Is there actually a patch ready to go to add the dictionary? If there is, then I don't see why we can't just check both in.

Gerv

Comment 9

5 years ago
Patch for dictionary: http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/rev/bf9bd258ccd2

Comment 10

5 years ago
http://hg.mozilla.org/releases/l10n/mozilla-beta/et/rev/bf9bd258ccd2 for beta.
(Reporter)

Comment 11

5 years ago
Gerv, I'm concerned at this point, because the readme has a license that differs from what's in your patch.

Notably, http://hg.mozilla.org/releases/l10n/mozilla-aurora/et/file/33b4be342038/extensions/spellcheck/hunspell/README_et.txt#l97

says

Whenever you use the Product, we request that you inform us by writing to the e-mail address tarkvara@eki.ee or to street address listed below. 

which is rather different from the "courtesy email us of derivative work" that's in your patch? The rest of the license seems to differ in details between the readme and the license on their website, too.
Flags: needinfo?(gerv)
(Assignee)

Comment 12

5 years ago
I used the latest version of their licence, which is here:
http://www.eki.ee/eki/licence.html

As far as I can tell, the only difference is in the wording of the request (not requirement) that they be notified about derivative works. Can you see other differences?

I think it's fine to use the latest version from their website, but we can use the one from the README if you prefer.

Gerv
Flags: needinfo?(gerv)
(Reporter)

Comment 13

5 years ago
If you're fine, I'm too.

Let's get this landed then.
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/0727b8480480

I assume that comment 13 was an implicit r+.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0727b8480480
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox23: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla23

Comment 16

5 years ago
Mozilla 23? Why 23? Dictionary is landed in 22 and Axel rejected my sign-off. I'm not going to remove it as I see no reason why it can't be in 22.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 17

5 years ago
We'll get to that in a second, but let's for now keep the resolutions as they should be. FIXED is just for central.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

5 years ago
Comment on attachment 738406 [details] [diff] [review]
about:license Patch v.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: No dictionary for Estonian in 22, hard to update the locale without
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): None, license plate change only
String or IDL/UUID changes made by this patch: None

We'd like to uplift this patch to aurora so that we can include the estonian dictionary with Firefox 22
Attachment #738406 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #738406 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 19

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/3391182c20b5, transplanted to aurora.
status-firefox22: affected → fixed
I confirm the fix is verified on FF23b5 on Windows 7x64, Ubuntu 13.04 x86 and Mac OS 10.9:

Estonian Spellchecking Dictionary License was added in about:license. 
URL: about:license#hunspell-ee

Build ID: 20130711122148
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.