Closed Bug 859928 Opened 7 years ago Closed 7 years ago

Gecko Profiler is broken for B2G

Categories

(Core :: Gecko Profiler, defect)

19 Branch
ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla23

People

(Reporter: dhylands, Assigned: dhylands)

References

Details

Attachments

(1 file)

It looks like the Gecko Profiler was changed in bug 851748 to save the profile files to /sdcard

Under b2g, not all processes have permission to write to the sdcard, so this means that the profile data is not captured if the process doesn't have sufficient permission (i.e. the HomeScreen app doesn't have write permission to the sdcard).

It used to write the files to /data/local/tmp. Under B2G, this is the only location on the phone which is writable by any app.

The error message also says: "Fail to open profile log file."

It would be really nice if it said what the filename that failed was.
Assignee: nobody → dhylands
I also added the filename to the error message which is printed when it's unable to save a file.
Attachment #735354 - Flags: review?(bgirard)
Attachment #735354 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/mozilla-central/rev/367df9ba7a51
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Duplicate of this bug: 861077
You need to log in before you can comment on or make changes to this bug.