Closed Bug 859994 Opened 7 years ago Closed 7 years ago

Remove the Marketplace promo from Fennec

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 23
Tracking Status
firefox20 --- affected
firefox21 + verified
firefox22 + verified
firefox23 + verified

People

(Reporter: mfinkle, Unassigned)

Details

Attachments

(3 files, 3 obsolete files)

Attached patch patch for m-c (obsolete) — Splinter Review
The marketplace promo should be removed from the product. We don't expect the marketplace to be ready for promotion until later in the year.
Attachment #735360 - Flags: review?(wjohnston)
Attached patch patch for beta (obsolete) — Splinter Review
The code in beta is a bit different from m-c and m-a, so here is a separate patch
Attachment #735361 - Flags: review?(wjohnston)
Attached patch patch for m-c v2 (obsolete) — Splinter Review
Removed menu and strings too
Attachment #735360 - Attachment is obsolete: true
Attachment #735360 - Flags: review?(wjohnston)
Attachment #735371 - Flags: review?(wjohnston)
Attached patch patch for m-c v3Splinter Review
Remove the menu handler
Attachment #735371 - Attachment is obsolete: true
Attachment #735371 - Flags: review?(wjohnston)
Attachment #735387 - Flags: review?(wjohnston)
Attachment #735387 - Flags: review?(wjohnston) → review+
Remove menus and menu handler. Leave strings
Attachment #735361 - Attachment is obsolete: true
Attachment #735361 - Flags: review?(wjohnston)
Attachment #735397 - Flags: review?(wjohnston)
Remove menus, promo and menu handler from release
Attachment #735398 - Flags: review?(wjohnston)
Comment on attachment 735397 [details] [diff] [review]
patch for beta v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: required product change
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: none

built and tested on beta
Attachment #735397 - Flags: approval-mozilla-beta?
Attachment #735397 - Flags: review?(wjohnston) → review+
Attachment #735398 - Flags: review?(wjohnston) → review+
Comment on attachment 735397 [details] [diff] [review]
patch for beta v2

Approving on beta as this is a required product change and assuming this is low risk.

Please make sure to highlight any risk or unknown user impact this may have before landing.Also cc'ing QA to help with verification once this lands on Beta.
Attachment #735397 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 735397 [details] [diff] [review]
patch for beta v2

landed on beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/875a71336901

Notes for QA: This should remove the Marketplace promo in About Home. It should also remove the "Apps" menu item.

* Test that only Sync promo appears. Then setup Sync. Now there should be no promo. Rotate screen a bit too, to make sure the layout works.
* Test on different android versions and tablets/phones because we use different menus for each. Make sure the "Apps" menu is gone from all device menus.
mfinkle, sry about the mid-air overriding , resetting the flags as you marked :)
Is this responsible for rc2 orange on mozilla-beta? It looks like there's a unit test that still expects the Apps item to be there. Probably a trivial fix, but someone who knows about it should have a look:

https://tbpl.mozilla.org/php/getParsedLog.php?id=21617194&tree=Mozilla-Beta

Android Tegra 250 mozilla-beta opt test robocop-2 on 2013-04-09 09:14:19 PDT for push 875a71336901
slave: tegra-192

25 INFO TEST-UNEXPECTED-FAIL | testSystemPages | Exception caught - junit.framework.AssertionFailedError: The text: ^Apps$ is not found!
04-09 16:42:47.094 I/Robocop ( 5196): 25 INFO TEST-UNEXPECTED-FAIL | testSystemPages | Exception caught - junit.framework.AssertionFailedError: The text: ^Apps$ is not found!
04-09 16:42:48.134 I/TestRunner( 5196): junit.framework.AssertionFailedError: 25 INFO TEST-UNEXPECTED-FAIL | testSystemPages | Exception caught - junit.framework.AssertionFailedError: The text: ^Apps$ is not found!
04-09 16:42:47.094 I/Robocop ( 5196): 25 INFO TEST-UNEXPECTED-FAIL | testSystemPages | Exception caught - junit.framework.AssertionFailedError: The text: ^Apps$ is not found!
04-09 16:42:48.134 I/TestRunner( 5196): junit.framework.AssertionFailedError: 25 INFO TEST-UNEXPECTED-FAIL | testSystemPages | Exception caught - junit.framework.AssertionFailedError: The text: ^Apps$ is not found!
VERIFIED FIXED on mozilla-beta (e986afca5664)
OS: Linux → Android
Hardware: x86_64 → ARM
Version: Firefox 15 → Trunk
VERIFIED FIXED on mozilla-release (026ee4d09662) over in bug 817775
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
I plan on landing this on m-c and aurora too
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Adjusting tracking/status to keep on top of mc and aurora
Comment on attachment 735387 [details] [diff] [review]
patch for m-c v3

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: they see the promo and go to the Marketplace. 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): low-already on beta and release
String or IDL/UUID changes made by this patch: none

I am only removing the promo, not the "App" menu (or any strings)
Attachment #735387 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/64903706cf0c
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Never again.
Status: RESOLVED → VERIFIED
Attachment #735387 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
Build: Firefox for Android 22 Beta 1 (2013-05-15)
Device: Samsung Galaxy Tab 
OS:Android 4.0.4
You need to log in before you can comment on or make changes to this bug.