Closed Bug 860053 Opened 7 years ago Closed 7 years ago

On first use, FM radio does not play even after moving dialer

Categories

(Firefox OS Graveyard :: Gaia::FMRadio, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED WORKSFORME
1.1 CS (11may)
blocking-b2g leo+

People

(Reporter: ggrisco, Unassigned)

Details

(Whiteboard: [CR 462003])

1. Startup FM radio for first time after loading a build (or after factory reset)

Expectation: Would expect that either the radio is in play state (pause button shown) and radio power comes on, or radio is in pause state and no radio is heard.
Actual Result:  Stop button is shown, indicating that we are in play state, but radio is not enabled.

2. drag the dialer to a station

Expectation:  radio should be enabled and we should hear radio play.
Actual result:  dialer moves, but radio is still not enabled.

3. Press stop button
4. Press start button

Radio can now be heard.
It looks like FM is intentionally turned off by default in gaia when there hasn't been any scanning history.  See historyList.init in gaia/apps/fm/js/fm.js.

The Play/Pause button is in the play position (Pause button shown) so I would expect it to start playing when scanner is moved up.
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Keywords: qawanted
Adding qawanted to help check if 1.0.1 is affected and have a tef ? accordingly.
Assignee: nobody → mshiao
Test with leo devices.
build id 20130414070204

I found my device is ok and can be heard.
Could not reproduce the bug.

After flashing and init fm, the button icon shows the play button then after a few seconds it switches to pause and the fm is on.  The same result where history has been deleted.

Seems to work as expected.

Tested with unagi and latest build
Unagi v1.0.1 cannot reproduce.
Device:   Unagi
Gaia:     3e7dda88950ae09166109783adea8181eb857d21
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/91fc54411a34
BuildID   20130414070204
Version   18.0


Inari v1.0.1 cannot reproduce.
Device:   inari
Gaia mozillaorg/v1.0.1 - 3e7dda88950ae09166109783adea8181eb857d21
Gecko mozillaorg/v1.0.1 - 4229cbbb556f7106351942628c21a64b3f77ae41
Unagi v1-train cannot reproduce.
Gaia:     bc1fd377bf73fa8b6af19a39b20866ffc203b87b
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18/rev/c0cd11d99953
BuildID   20130414230206
Version   18.0
qawanted request answered in comment 5
removing keywords tag
Keywords: qawanted
Target Milestone: --- → 1.1 CS (11may)
unassigning myself due to the fact that QA and I can not reproduce the bug.
Assignee: mshiao → nobody
Hi Greg,

Can you confirm that this is no longer an issue?  A few folks have tested and could not reproduce the issue.  

Thanks,
Mark
Flags: needinfo?(ggrisco)
I still see exactly the same problem stated in the Description.  Is there any other information I could collect to help you see what I'm seeing?
Flags: needinfo?(ggrisco)
Just did a factory reset and tested this on the build 20130505070205 and cannot see this problem described. 
Soon after the radio is loaded I have the frequency defaulted at 87.5 and hearing static with the "Stop" button displayed, implying radio playing.

:m1, given the people trying but unable to see the problem and that the original bug description says it occurs on first time boot only, should this bug be CS blocking?
Flags: needinfo?(mvines)
Hey Greg, 
Could you please try this on a leo device here?  Comment 3 says it doesn't reproduce there.  If this issue only manifests on the QRD then I think we could potentially close this bug.
Flags: needinfo?(mvines) → needinfo?(ggrisco)
Yeah, on leo it looks ok.  I only saw this issue on QRD.
Flags: needinfo?(ggrisco)
It's ok on beetle as well.  I'll withdraw this bug then.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.