Closed Bug 860187 Opened 7 years ago Closed 7 years ago

[Buri][SMS]When viewing the message content, sometimes "back" is not working

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 QE1 (5may)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: sync-1, Assigned: borjasalguero)

References

()

Details

(Whiteboard: [QE1][TD-9648])

Attachments

(1 file)

AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.19.053
 Firefox os  v1.0.1
 Mozilla build ID: 20130327153857
 
 +++ This bug was initially created as a clone of Bug #433373 +++
 
 DEFECT DESCRIPTION:
 (1)There are some new message notifications available
 (2)Open the sms APP by the notification, go to the message list
 (3)Press one new message thread , to open the thread content.
 (4)Press back key, no response ----- NOK
 
 In this case, have to kill sms by application manager, it can recover.
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 Back should always work.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 Big
  REPRODUCING RATE:
 50%
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #433373 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Assignee: nobody → fbsc
Duplicate of this bug: 859224
Depends on: 847975
Attached file Pull Request
Attachment #736186 - Flags: review?(felash)
Duplicate of this bug: 852169
Steps To Reproduce (STR):
- Open SMS App
- Click 'New'
- Type something in the 'Contact live search' with NO results
- Type something in message field
- Hide keyboard
- Tap in BACK

EXPECTED:
- Confirm with 'Do you want to delete...'

CURRENTLY.
- Nothing happens.
Comment on attachment 736186 [details]
Pull Request

r=me

thanks
Attachment #736186 - Flags: review?(felash) → review+
note: the "- Type something in message field" step is even not necessary to trigger this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 736186 [details]
Pull Request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 847975
User impact if declined: sometimes the back button doesn't work
Testing completed: yes
Risk to taking this patch (and alternatives if risky): very low
String or UUID changes made by this patch: none

This fixes a regression introduced by Bug 847975.
Attachment #736186 - Flags: approval-gaia-v1?(21)
Requesting leo+ -- duplicate bug 859224 got a leo+ before it was duped to this one.
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Comment on attachment 736186 [details]
Pull Request

No longer need approval since this is leo+
Attachment #736186 - Flags: approval-gaia-v1?(21)
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 b430b9af8d0ddb9289622731a3d13c2c80242dfa
  <RESOLVE MERGE CONFLICTS>
  git commit
You need Bug 847975 uplifted before this one (as this is a regression).

I'll take care of these. :)
v1-train: 5e21be8d73d08efaedc6e4bd7096e52f913ab479
Verified the defect with the pull request.Able to reproduce the issue even after merging the pull request.

Reproducing steps:
1.Receive and accept a call
2.Receive an sms during call
3.Open the sms,click on the back button.
4.Back button is not working.

Please check this once again.
Whiteboard: [QE1]
Please check the below comments with the latest code

1.In latest code the thread_list is not showing with all the list of threads.It is overriding the previous thread with new thread.
2.In thread view,no messages are visible.

This is the error showing in the console:
[JavaScript Error: "TypeError: message.timestamp is undefined" {file: "app://sms.gaiamobile.org/js/thread_ui.js" line: 574}]

Please verify it once.
Please file 2 new bugs, your comments are not directly related to this bug.

For example the line referenced in Comment 16 comes from the uplift for Bug 838005 (even if the cause can be elsewhere).

And FTR I can't reproduce Comment 15 so this really belongs to a new bug so that we can investigate.

Thanks !
Whiteboard: [QE1] → [QE1][TD-9648]
Target Milestone: --- → Leo QE1 (5may)
This issue still exist.

AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.077
Firefox os  v1.0.1
Mozilla build ID:20130414070204
xiupinglong please see bug 862298, that's where the problem with the Commercial RIL is handled.
Flags: in-moztrap?
UCID: owd-13782
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.