Closed Bug 860253 Opened 10 years ago Closed 9 years ago

Partial and sliding rendering of webpages in Print Preview mode (recent regression)

Categories

(Core :: Print Preview, defect)

23 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla23
Tracking Status
firefox22 --- unaffected
firefox23 --- verified

People

(Reporter: epinal99-bugzilla2, Assigned: robert)

References

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1) Open http://www.mozilla.org/en-US/
2) Print Preview

Result: Rendering of the webpage is sliding and partial when the user is scrolling in print preview mode.

Regression range:
m-c
good=2013-04-05
bad=2013-04-06
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=55f9e3e3dae7&tochange=768af8d8fad4
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/905671d954c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405053752
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/1e958f7224a7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405054152
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=905671d954c5&tochange=1e958f7224a7
Just saw this bug for first time on 23.0a1 (2013-04-13), though it is regression to ya'll...  

This is just like in the http://www.youtube.com/watch?v=3230eG-jdns&feature=youtu.be attachment of bug 812107; except that in Linux, it occurs from the top down. Also, note at the 2 second point in that video how the initial document top is several pixels down from the top of the display area, then moves up.  In my case, on Linux, the display area starts out the same way; document top moves up as in the video until it reaches the virtual top of the display area, pauses**, then the display area shrinks from the top.

** As I very slowly scroll down, the top edge of the document moves up. When it reaches the top, it takes another one+ (can't tell how many) scroll ticks before the display area starts shrinking from the top.  HTH
Attachment #737374 - Flags: review?(matt.woodrow) → review+
Bug still present on 23.0a1 (2013-04-15)
https://hg.mozilla.org/mozilla-central/rev/4e5466c76923
Assignee: nobody → robert
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Duplicate of this bug: 861649
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:23.0) Gecko/20130428 Firefox/23.0

Verified as fixed on Firefox latest nightly (Build ID:20130428031010).
Changing status and tracking flags according to Mitza's comment.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.