Closed Bug 860380 Opened 9 years ago Closed 8 years ago

The slide show on the homepage at www.babygooroo.com not working (jquery.slidedeck)

Categories

(Web Compatibility :: Desktop, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Swarnava, Unassigned)

References

()

Details

Since a recent update the slide show feature on websites babygooroo.com no longer works. 

Related Discussion:- https://support.mozilla.org/questions/956129
Please include me in notification of any updates that resolve this issue.
The console shows: "This web browser is not supported by SlideDeck. Please view this page in a modern, CSS3 capable browser or a current version of Inernet Explorer"

This message comes from slidedeck.jquery.lite.js:652:

if((self.browser.opera && self.browser.version < "10.5") || self.browser.msie6 || self.browser.firefox2 || self.browser.firefox30){
                if(typeof(console) != "undefined"){
                    if(typeof(console.error) == "function"){
                        console.error("This web browser is not supported by SlideDeck. Please view this page in a modern, CSS3 capable browser or a current version of Inernet Explorer");
                    }
                }
                return false;
            }

And in this block passes cause self.browser.firefox2 is true.

browser.firefox2 is set in slidedeck.jquery.lite.js:85:
firefox2: UA.match(/firefox\/2/) ? true : false,

So this is caused by a broken ua sniffer finding firefox/2 in firefox/20.
Assignee: nobody → english-us
Component: Untriaged → English US
Product: Firefox → Tech Evangelism
Version: 20 Branch → Trunk
Temporary workaround is to go to about:config, create a new string value named general.useragent.override.babygooroo.com

and enter a useragent with firefox/20 replaced with firefox/19.
Summary: The slide show on the homepage at www.babygooroo.com not working → The slide show on the homepage at www.babygooroo.com not working (jquery.slidedeck)
The slidedeck is working on babygooroo.com
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 8 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.