Last Comment Bug 860454 - UpdateService failing with java.net.URISyntaxException
: UpdateService failing with java.net.URISyntaxException
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: Firefox 23
Assigned To: Brian Nicholson (:bnicholson) (PTO through August 1)
:
Mentors:
: 861845 (view as bug list)
Depends on:
Blocks: 856163
  Show dependency treegraph
 
Reported: 2013-04-10 13:16 PDT by Nick Alexander :nalexander
Modified: 2013-04-18 02:03 PDT (History)
5 users (show)
aaron.train: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove space from UpdateServiceHelper (1.35 KB, patch)
2013-04-10 13:35 PDT, Brian Nicholson (:bnicholson) (PTO through August 1)
mark.finkle: review+
Details | Diff | Splinter Review

Description Nick Alexander :nalexander 2013-04-10 13:16:39 PDT
This is with a Fennec built a few hours ago, based on hg revision

https://hg.mozilla.org/integration/mozilla-inbound/rev/49b44cd1cdb1

The space in the URI is "obviously" wrong.

I UpdateService(25085)        openning connection with url: https://aus2.mozilla.org/update/4/Fennec/23.0a1/20130410111658/Android_ arm-eabi-gcc3/en-US/default/4.0.3/default/default/23.0a1/update.xml
E UpdateService(25085)        failed to check for update: 
E UpdateService(25085)        java.net.URISyntaxException: Illegal character in path at index 71: https://aus2.mozilla.org/update/4/Fennec/23.0a1/20130410111658/Android_ arm-eabi-gcc3/en-US/default/4.0.3/default/default/23.0a1/update.xml
E UpdateService(25085)        	at libcore.net.UriCodec.validate(UriCodec.java:63)
E UpdateService(25085)        	at java.net.URI.parseURI(URI.java:402)
E UpdateService(25085)        	at java.net.URI.<init>(URI.java:204)
E UpdateService(25085)        	at java.net.URL.toURI(URL.java:497)
E UpdateService(25085)        	at org.mozilla.gecko.updater.UpdateService.openConnectionWithProxy(UpdateService.java:278)
E UpdateService(25085)        	at org.mozilla.gecko.updater.UpdateService.findUpdate(UpdateService.java:292)
E UpdateService(25085)        	at org.mozilla.gecko.updater.UpdateService.startUpdate(UpdateService.java:191)
E UpdateService(25085)        	at org.mozilla.gecko.updater.UpdateService.registerForUpdates(UpdateService.java:161)
E UpdateService(25085)        	at org.mozilla.gecko.updater.UpdateService.onHandleIntent(UpdateService.java:116)
E UpdateService(25085)        	at android.app.IntentService$ServiceHandler.handleMessage(IntentService.java:65)
E UpdateService(25085)        	at android.os.Handler.dispatchMessage(Handler.java:99)
E UpdateService(25085)        	at android.os.Looper.loop(Looper.java:137)
E UpdateService(25085)        	at android.os.HandlerThread.run(HandlerThread.java:60)
I UpdateService(25085)        no update available
Comment 1 Brian Nicholson (:bnicholson) (PTO through August 1) 2013-04-10 13:35:12 PDT
Created attachment 735944 [details] [diff] [review]
Remove space from UpdateServiceHelper
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2013-04-10 13:40:51 PDT
Comment on attachment 735944 [details] [diff] [review]
Remove space from UpdateServiceHelper

Please land on m-c to reduce the time to get in a nightly
Comment 3 Brian Nicholson (:bnicholson) (PTO through August 1) 2013-04-10 14:05:19 PDT
https://hg.mozilla.org/mozilla-central/rev/a6fb03a70c9d
Comment 4 Ben Hearsum (:bhearsum) 2013-04-15 06:19:54 PDT
*** Bug 861845 has been marked as a duplicate of this bug. ***
Comment 5 Ben Hearsum (:bhearsum) 2013-04-15 06:21:24 PDT
In the future it would be good to get updates turned off temporarily in these situations, to avoid stranding portions of our user base on builds with issues like the one described here. RelEng can do this very quickly if you drop by #releng or file a blocker bug in mozilla.org: Release Engineering the next time something like this comes up.

Note You need to log in before you can comment on or make changes to this bug.