Closed Bug 860475 Opened 7 years ago Closed 7 years ago

Can't build debug gecko on trunk: fatal error: libxul.so: mmap: failed to allocate 865003876 bytes

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 854535

People

(Reporter: gwagner, Unassigned)

Details

enable debug, disable optimize is broken on mac:

/Volumes/2mac/unagi/1/B2G/prebuilt/darwin-x86/toolchain/arm-linux-androideabi-4.4.x/bin/../lib/gcc/arm-linux-androideabi/4.4.3/../../../../arm-linux-androideabi/bin/ld: fatal error: libxul.so: mmap: failed to allocate 865003876 bytes for output file: Cannot allocate memory
collect2: ld returned 1 exit status
make[6]: *** [libxul.so] Error 1
make[5]: *** [libs_tier_platform] Error 2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854535
You need to log in before you can comment on or make changes to this bug.