pdf.js / pdf preview does not show personalized Text (watermark)

RESOLVED FIXED

Status

()

P3
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: imarquardt, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3867)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:

We personalize pdf documents (Using PDFTron PDFNet library). The watermark text is shown right in Acrobat and other Tools, but not in the intern pdf preview of firefox (Foxit Reader).

Here is an example pdf to reproduce the issue:
http://www.makrolog.de/firefoxBug.pdf


Actual results:

In the example, there is no vertical watermark text at the left of each page in Foxit Reader.


Expected results:

The text "This text is not shown in Firefox but in external Acrobat" should be visible, but is only in Acrobat Reader and other Tools
(Reporter)

Comment 1

6 years ago
Created attachment 736163 [details]
The PDF in Acrobat with text (extra marked in yellow)
(Reporter)

Comment 2

6 years ago
Created attachment 736164 [details]
The PDF as Firefox Preview without text

Comment 3

6 years ago
Are you talking about pdf.js or embeded foxit reader?

I can reproduce it in pdf.js but if you see the problem with foxit reader you need to take it up with them.
(Reporter)

Updated

6 years ago
Summary: Foxit Reader / PDF Preview does not show personalized Text (watermark) → pdf.js / pdf preview does not show personalized Text (watermark)
(Reporter)

Comment 4

6 years ago
yes, it is in pdf.js - sorry (I thought it was foxit reader because of an support screenshot which I have received). I've changed it in the title
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Version: 20 Branch → Trunk

Updated

6 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-annoations]

Updated

6 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-annoations] → [pdfjs-c-rendering][pdfjs-d-font-conversion]

Updated

5 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-font-conversion] → [pdfjs-c-rendering][pdfjs-d-font-conversion][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/3867

Comment 5

4 years ago
Fixed by bug 937670.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 937670
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.