Wrong behauvior onmouseover (RSA.COM)

RESOLVED DUPLICATE of bug 92248

Status

()

RESOLVED DUPLICATE of bug 92248
18 years ago
5 years ago

People

(Reporter: sander, Assigned: pavlov)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
1. Load the page
2. Move your mouse over the top bar,
For some tabs the icon changes as expected. For others white box apears
with the text in it. Perhaps containing the ALT text.

Comment 1

18 years ago
This seems to be a dupe of http://bugzilla.mozilla.org/show_bug.cgi?id=32269
which is marked fixed.. I don't get the error in the url provided in 32269 but I
get this one. Seems to be the same behaviour as described there though. Images
are changed onMouseOver and until they are cached Mozilla displays the ALT text
instead of waiting until the image is ready. 

Suggest reopening http://bugzilla.mozilla.org/show_bug.cgi?id=32269 and marking
this a dupe of that one.

Comment 2

18 years ago
Here's sample HTML and JavaScript from the site showing how images
are swapped: 

<td colspan="2" valign="top" height="27">

<a href="/products/" onMouseOut="RSA_swapImgRestore()" 
onMouseOver="RSA_swapImage('rsa_top_nav_off_02','','/images/rsa_top_nav_on_02.gi
f','navroll','','/images/nav_roll_products.gif',2)">

<img name="rsa_top_nav_off_02" src="/images/rsa_top_nav_off_02.gif" width="74" 
height="28" border="0" alt="PRODUCTS">

</a>
</td>




<script language="JavaScript">
<!--
function RSA_swapImgRestore() {
	var i, x, a = document.RSA_sr;
	for(i = 0; a && i < a.length && (x = a[i]) && x.oSrc; i++) {
		x.src = x.oSrc;
	}
}

function RSA_findObj(n, d) {
	var p, i, x;
	if(!d) {
		d = document;
	}
	if((p = n.indexOf("?")) > 0 && parent.frames.length) {
		d = parent.frames[n.substring(p+1)].document;
		n = n.substring(0, p);
	}
	if(!(x = d[n]) && d.all) {
		x = d.all[n];
	}
	for(i = 0; !x && i < d.forms.length; i++) {
		x = d.forms[i][n];
	}
	for(i = 0; !x && d.layers && i < d.layers.length; i++) {
		x = RSA_findObj(n, d.layers[i].document);
	}
	
	return x;
}

function RSA_swapImage() {
	var i, j = 0, x, a = RSA_swapImage.arguments;
	document.RSA_sr = new Array;
	for(i = 0; i < (a.length - 2); i += 3) {
		if((x = RSA_findObj(a[i])) != null) {
			document.RSA_sr[j++] = x;
			if(!x.oSrc) {
				x.oSrc = x.src;
			}
			x.src = a[i + 2];
		}
	}
}

function goThere() {
	var list = document.goForm.International
	if (list.options[list.selectedIndex].value != "none") {
		window.location = list.options[list.selectedIndex].value}
}
//-->
</script>

Comment 3

18 years ago
Created attachment 38629 [details]
The HTML with debugging code added to RSA_swapImage()

Comment 4

18 years ago
Confirming bug with Mozilla binaries 20010613xx on WinNT, Linux.
OS: WinNT --> All.

Try the HTML with debugging code above. You get alertboxes from
RSA_swapImage() every time you do a mouseover. 

With this HTML, I never get the ALT text. On the other hand, the new
image (with the red arrow to the left of the text item) almost never
loads. It loads the first time I do a mouseover on any of the top
menu items, and then never loads again. That is, I never get any more
red arrows. 

However, if I Alt+Tab to another application, then Alt+Tab back to 
Mozilla, I once again get a red arrow on the first mouseover I do.
Again, I never get any ALT text with the debugging HTML.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All

Comment 5

18 years ago
Not JS Engine. Reassigning to DOM 0 and Pav as in bug 32269 - 
Assignee: rogerl → pavlov
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale

Comment 6

18 years ago
The js code used for the image swapping seems to be the same as you get with the
Swap Image Behaviour in Macromedia Dreamweaver. They just changed the MM bit of
the function names to RSA and reformatted the code. 

I'll try to recreate the bug with Dreamweaver using larger images, making the
bug more visible.
(Assignee)

Updated

18 years ago
Target Milestone: --- → mozilla0.9.3

Comment 7

17 years ago
Doesn't look like this is getting fixed before the freeze tomorrow night.
Pushing out a milestone.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → Future

Comment 8

17 years ago
With NS 6.1 as well as Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:0.9.3+) Gecko/20010829.

I see this problem in many pages.  For example, try
http://www.star-components.com/ (the tabs use onMouseOver) and
http://www.netscapecard.com (The four small red buttons have onMouseOver
behaviour. If you have a Netscape card, log in for lots more problems than just
the ones that can be seen on the front page ...)

Many other pages on the web, but I can't remember them right now.  I encounter
this problem often.  I'll add URLs here as I go encountering them.

Is there anything that we can do to get this looked at sooner than "future" ...
 It gives a really bad impression of the browser given the high use of this
feature on the pages in the WWW today.

Comment 9

17 years ago
think this is related to bug 92248

Comment 10

17 years ago
build 2001100303 win32

looks like a dup of bug 92248, though the funny thing is that I don't always see
it. Making it a depend for now. And if anyone is really interested in helping,
creating a simplified testcase would be helpful. The testcase with debugging
code is not helpful at all.
Depends on: 92248

Comment 11

17 years ago
build 2001101603 win32 trunk

bug 92248 seems like fixed

this WFM

Comment 12

17 years ago
this is dup of bug 92248. Currently fixed in trunk (build 2001102903 win32)

*** This bug has been marked as a duplicate of 92248 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
Summary: Wrong behauvior onmouseover → Wrong behauvior onmouseover (RSA.COM)
You need to log in before you can comment on or make changes to this bug.