Marionette shouldn't attempt to process minidumps after every test run.

RESOLVED FIXED in mozilla23

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ahal, Assigned: ahal)

Tracking

unspecified
mozilla23
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
I integrated the minidump processing into marionette.check_for_crash:
http://mxr.mozilla.org/mozilla-central/source/testing/marionette/client/marionette/marionette.py#390

But this gets called after each test, so we are running minidump_stackwalk after each test. I don't think this is the desired behaviour. I can either:
A) pull this out into it's own "check_for_minidumps" method
B) pass in a "process_minidump" flag to the check_for_crash method, and only process at the end of the test run. The other times would just return True/False if a minidump file exists without running minidump_stackwalk on it.

I'm not 100% sure what the desired case is here. Option A has less overhead and will make runs slightly faster. But if we do option B it might mean that test runs will be aborted instead of socket timeouts on b2g process crash (though I'm not positive this will be the case).
The current check_for_crash() method was intended to abort the test run when the emulator itself (rather than gecko) crashed.  It's never worked quite right, although we don't seem to have emulator crashes these days, so it's hard to say what its current status is.

We really need to implement a method that checks for both kinds of crashes at the end of each test, and that will successfully abort the run if one has occurred.  I think your option B) will get us part way there; the other part is some more changes to the test runner to make the test aborting more successful, but we can handle that in a separate bug.
(Assignee)

Comment 2

6 years ago
Created attachment 736452 [details] [diff] [review]
Patch 1.0 - don't check remote_profiles each time

Actually, I made a quick optimization (don't check remote_profiles each time) and with this change the difference in time between this and not running check_for_crashes after each test is negligible. So I propose we leave things as they are (with this patch).
Attachment #736452 - Flags: review?(jgriffin)
Comment on attachment 736452 [details] [diff] [review]
Patch 1.0 - don't check remote_profiles each time

Review of attachment 736452 [details] [diff] [review]:
-----------------------------------------------------------------

Nice solution.
Attachment #736452 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/mozilla-central/rev/505c6b2c7f66
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.