address autocomplete behaviour has changed, contains matching string

VERIFIED DUPLICATE of bug 85340

Status

VERIFIED DUPLICATE of bug 85340
18 years ago
11 years ago

People

(Reporter: bulbul, Assigned: bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The behaviour of address autocomplete has changed. So hard to describe. Please
bear with me.

1. In the "To" field, type in part of an e-mail address which you know 
   will be a successful autocomplete. For example, i know that typing 
   "bulbul" will be found. This used to give me:

       Leston Buell <bulbul@ucla.edu>

   This still correctly appears in the drop-down menu, but the line 
   in the "To:" field now gives me:

       bulbul >> Leston Buell <bulbul@ucla.edu>

2. Hit "return", selecting the autocomplete version with the matching 
   string and ">>".

3. Now send the message. The matching string and the ">>" are both 
   included in the "To:" field. This can be confirmed by examining 
   the headers of the received e-mail. So, when i receive the message, 
   it says:

       To: "bulbul >> Leston Buell" <bulbul@ucla.edu>

This behaviour is obviously incorrect.
(Reporter)

Comment 1

18 years ago
Sorry, forgot to include my build info. It's Linux 2001061508.

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 85340 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 3

18 years ago
verified as dup 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.