Make "More..." at bottom of History subview show completely

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: jaws)

Tracking

Trunk
Firefox 28
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Jared and I ran into a weird problem where the "More..." at the bottom of the History widget subview was being truncated.

We need to fix this.

Comment 1

5 years ago
I think the history subview could be done differently.

There should be first three general items :
-Show all history instead of "more" at the bottom.
-Clear recent History... -> bring the clear history dialog or second subview.
-Restore previous session.

If possible "Recently closed" (tabs and windows will be merged) -> this too would need UI (second subview ?).

And then the history last items.

If general commands aren't present it would be a pretty big regression compared to the old menu and these items would be accessible only via the menu bar and shortcuts. 

I know that subview inside a subview looks a bit "Inception-esque" but for certain items it should be at least considered.
Created attachment 737065 [details] [diff] [review]
Patch
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #737065 - Flags: review?(mconley)
Comment on attachment 737065 [details] [diff] [review]
Patch

Review of attachment 737065 [details] [diff] [review]:
-----------------------------------------------------------------

We're going to eventually need a way to artificially constrain the maximum height of sub-views, filed bug 861703 for that.

::: browser/base/content/panelUI.js
@@ +58,5 @@
>  
> +    var self = this;
> +    this.subViews.addEventListener("overflow", function() {
> +      // Resize the subview on the next tick.
> +      Services.tm.currentThread.dispatch(self._syncContainerWithSubView.bind(self),

Nit: Mixing self and bind. Since we don't care about removing the event listener, this could potentially be refactored to:

this.subViews.addEventListener("overflow", function() {
  // Resize the subview on the next tick.
  Services.tm.currentThread.dispatch(this._syncContainerWithSubView.bind(this),
    Ci.nsIThread.DISPATCH_NORMAL);
}.bind(this));
Attachment #737065 - Flags: review?(mconley) → review+
https://hg.mozilla.org/projects/ux/rev/6464ab3879cc
Whiteboard: [fixed in jamun] → [fixed in jamun][fixed-in-ux]

Comment 6

5 years ago
https://hg.mozilla.org/mozilla-central/rev/6464ab3879cc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed in jamun][fixed-in-ux]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.