Displays wrong German Umlauts in mails when viewed as Original-Html

RESOLVED DUPLICATE of bug 594646

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 594646
5 years ago
5 years ago

People

(Reporter: Lutz Nevermann, Unassigned)

Tracking

SeaMonkey 2.17 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
Build ID: 20130331213155

Steps to reproduce:

Viewing mails with Seamonkey 2.16 or 2.17 (does not happen in 2.15.2!)


Actual results:

German (actually not only German) special characters are displayed wrongly.
Some examples show how it looks
GrÌße or für or nötig or hängt or MÀrz or é or „“


Expected results:

Same examples with the right characters look like this
Grüße or für or nötig or hängt or März or é or „“

Funny thing is, there are two different possibilities like ÃŒ or ü for ü depending on the sender.
This does not happen to all mails but only individual senders.
It does not happen in 2.15.2.
It only happens in mails viewed as Original-Html not view as simple-Html or plain-Text.
It's not may stetting Character encoding (tried it).
It's not "Content-Type" nor "Charset" nor "Content-Transfer-Encoding" 

It does not happen in print preview nor print nor forwarding, replying, edit as new.
(Reporter)

Updated

5 years ago
Component: General → MailNews: Message Display

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594646
You need to log in before you can comment on or make changes to this bug.