Last Comment Bug 861217 - add tests for scrollWidth on a table data TD cell in a fixed-layout table
: add tests for scrollWidth on a table data TD cell in a fixed-layout table
Status: RESOLVED FIXED
[mentor=bz][lang=js]
:
Product: Core
Classification: Components
Component: DOM: CSS Object Model (show other bugs)
: 20 Branch
: All All
: -- normal (vote)
: mozilla23
Assigned To: Daniel Trebbien
:
Mentors:
Depends on: 833542
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-12 08:48 PDT by Daniel Trebbien
Modified: 2013-04-24 13:25 PDT (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case (484 bytes, text/html)
2013-04-12 08:48 PDT, Daniel Trebbien
no flags Details
Proposed Mochitest test case - dom/tests/mochitest/general/test_bug861217.html (5.92 KB, text/plain)
2013-04-21 07:34 PDT, Daniel Trebbien
no flags Details
Patch (7.15 KB, patch)
2013-04-23 04:33 PDT, Daniel Trebbien
bzbarsky: review+
Details | Diff | Review

Description Daniel Trebbien 2013-04-12 08:48:49 PDT
Created attachment 736840 [details]
Test case

When the width of a TD is restricted in a fixed-layout table (table-layout:fixed), the TD's reported scrollWidth may be incorrect.

Please see the attached test case. I have tested Firefox 20.0, Firefox ESR 17.0.5, and Firefox 12.0 and found that the scrollWidth of `theTD' is 98. In Firefox Beta 21.0, Firefox Aurora 22.0a2 (2013-04-12), Chrome 26.0.1410.65, Safari 6.0.3, and IE 9, the scrollWidth is correct, ~293.

I used mozregression and found:

Last bad nightly (contains this issue): 2013-01-29
First good nightly (fixed): 2013-01-30

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0c45e6378f1f&tochange=677e87c11252

This range includes the patch for Bug 833542, and I think that the 833542 patch also fixed this bug.
Comment 1 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-04-12 08:56:54 PDT
So I'm confused.  If this is fixed... what's this bug about, exactly?
Comment 2 Daniel Trebbien 2013-04-12 09:00:07 PDT
This is fixed, yes. I wasn't sure if another test case should be created specifically for this bug given that the 833542 patch seems to have fixed this bug unintentionally.
Comment 3 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-04-12 09:02:32 PDT
Ah, I see.
Comment 4 Daniel Trebbien 2013-04-21 07:34:33 PDT
Created attachment 740089 [details]
Proposed Mochitest test case - dom/tests/mochitest/general/test_bug861217.html

Attached is my proposed Mochitest test file. When I run the test file in a build of Firefox @ 129356:4420f27742c7, I get the following result:

Passed: 32
Failed: 0
Todo: 0
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-04-22 20:55:39 PDT
Daniel, would you mind attaching that in diff form?
Comment 6 Daniel Trebbien 2013-04-23 04:33:53 PDT
Created attachment 740755 [details] [diff] [review]
Patch
Comment 7 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-04-23 22:11:01 PDT
Comment on attachment 740755 [details] [diff] [review]
Patch

Yeah, much better.  ;)  Now you just want to request review.  But since I'm here anyway, r=me, and thank you!
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-04-24 05:39:02 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/143986e6bd90
Comment 9 Daniel Trebbien 2013-04-24 06:07:15 PDT
Awesome! Thank you!

I guess this can be marked "FIXED"?
Comment 10 Boris Zbarsky [:bz] (Out June 25-July 6) 2013-04-24 07:27:35 PDT
It will be once it's merged over to mozilla-central.
Comment 11 Ryan VanderMeulen [:RyanVM] 2013-04-24 13:25:25 PDT
https://hg.mozilla.org/mozilla-central/rev/143986e6bd90

Note You need to log in before you can comment on or make changes to this bug.