Website redirects you when the language is changed

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: u452416, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20130412 Firefox/22.0
Build ID: 20130412004014

Steps to reproduce:

When clicking in the option list in the bottom of the page www.mozilla.org/en-US/mobile/sync/ to change the language to pt-BR, we are redirected to the main page www.mozilla.org/en-US/


Actual results:

The site redirects you and don't change the language


Expected results:

The same page should be reloaded with the selected language

Comment 1

6 years ago
Moving to a more appropriate component.
Component: pt-BR / Portuguese (Brazil) → L10N
Product: Mozilla Localizations → www.mozilla.org

Updated

6 years ago
Blocks: 879544
Yeah, it's a known issue on the legacy site, where the language selector shows all languages regardless of the actual localizations of the page.

The language selector on the new Bedrock site platform, that I have implemented in Bug 773371, only shows the available localizations of the page.

The issue is fixed when the page is migrated to the new platform.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: L10N → Legacy PHP system
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.