Need to update emulator in tooltool for B2G emulator testing for Bug 860585

RESOLVED FIXED in B2G C4 (2jan on)

Status

RESOLVED FIXED
6 years ago
6 months ago

People

(Reporter: edgar, Assigned: Callek)

Tracking

other
B2G C4 (2jan on)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
We need to update the emulator used by TBPL emulator tests to pick up a fix for bug 860585, specifically the commit https://github.com/mozilla-b2g/platform_external_qemu/commit/4aa21d60a6ba2927122d82ceb433c3e4f690176f

Thanks
jgriffin, please generate the emulator build for us to put on tooltool.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 860506
(Assignee)

Updated

6 years ago
Assignee: nobody → bugspam.Callek
(Assignee)

Comment 4

6 years ago
Created attachment 737402 [details] [diff] [review]
[m-c] emulator
Attachment #737402 - Flags: review?(echen)
The patch looks fine, we'll need to do a full try run before checking this in.  I'll kick one off.
(Reporter)

Updated

6 years ago
Attachment #737402 - Flags: review?(echen) → review?(jgriffin)
Pushed to try again along with the patch from bug 840315, which may be necessary to avoid breaking font-sensitive tests:  https://tbpl.mozilla.org/?tree=Try&rev=424e1b710ce9
These try jobs were pretty bad, but most of that was fixed up in bug 840315.  I've just pushed again to try: https://tbpl.mozilla.org/?tree=Try&rev=631db7a026f9
Created attachment 738043 [details] [diff] [review]
Update the emulator,

Try run was green.  I updated the patch to account for some bitrot, bit looks good to land.
Attachment #737402 - Attachment is obsolete: true
Attachment #737402 - Flags: review?(jgriffin)
Attachment #738043 - Flags: review+
checkin-needed for mozilla-b2g18 as well, when this migrates to mozilla-central
Keywords: checkin-needed
https://hg.mozilla.org/projects/birch/rev/32fc13973b34

Is this exact patch what's needed on b2g18?
Keywords: checkin-needed
Whiteboard: [fixed-in-birch]
it may not apply cleanly to mozilla-b2g18.  I'll uplift it after it hits m-c.
Turns out we need v1-train emulators for mozilla-b2g18; will have to handle that with a separate bug.
https://hg.mozilla.org/mozilla-central/rev/32fc13973b34
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → B2G C4 (2jan on)
(Reporter)

Updated

6 years ago
Depends on: 860682
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.