[Bluetooth] Disconnection when CK try to update phonebook

RESOLVED WONTFIX

Status

Firefox OS
Bluetooth
P1
normal
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gecko, Assigned: shawnjohnjr)

Tracking

({feature})

unspecified
1.1 QE1 (5may)
x86
Windows XP
feature

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [TD-11430])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
GENERAL Defect Description 
1. Title : [BT/ BT CAR KIT] Disconnection when CK try to update phonebook
2. Precondition : Porsche PCM 3.1 , PSA RT6
DUT  doesn’t support PBAP so phonebook is not updated. Although on Porsche PCM 3.1 you are prompt to download it manually. 
3. Tester's Action : 
Go to OPTIONS -> SET PHONE -> TRANSFER PHONEBOOk
4. Detailed Symptom (ENG.) : 
When you do this DUT is disconnected and automatically reconnected. 
On RT6 you receive some contacts synchronization errors (but DUT will not disconnect).
6. Expected : No disconnection or phonebook errors displayed on CK
7.Reproducibility: Y
1)Frequency Rate : 100%
(Reporter)

Comment 1

5 years ago
Created attachment 737212 [details]
disconnection when update contacts

Dear Mozilla Team,

Dear Mozilla Team,

I upload the air log for this issue.
Please check this.

Thanks.
(Reporter)

Updated

5 years ago
Whiteboard: [TD-11430]
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 2

5 years ago
Dear Mozilla Team,

As I tested on this bug, it occurs even in the latest version of gecko hfp.
When the phone is received CPBS command from Porsche PCM 3.1, phone return ERROR.
But at this time Carkit seems to send the disconnect request to phone.
Can you check this point in air log?

Thanks.
Target Milestone: --- → Leo QE1 (5may)

Comment 3

5 years ago
leo.bugzilla.gecko needs to provide a new non-binary log

Is there anything we can do here Shawn?
Flags: needinfo?(shuang)
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 4

5 years ago
Dear Alex,

Attached log is not a binary file and it is important for analyzing.
BT team including Shawn will be able to see this log.

Thanks.
Flags: needinfo?(leo.bugzilla.gecko)
leo team - the attached file is a .cfa which is some sort of binary audio file - if that's incorrect please edit the details of the attachment or re-attach with proper file type & extension?
Flags: needinfo?(leo.bugzilla.gecko)
(Reporter)

Comment 6

5 years ago
Dear Mozilla Team,

The attached file is a FTS log file.
This is written the air log between phone and carkit, not a binary.
You used the File viewer of FTS program?
Flags: needinfo?(leo.bugzilla.gecko)
(Assignee)

Updated

5 years ago
Assignee: nobody → shuang
(Assignee)

Comment 7

5 years ago
Yes, I've checked the log, PSM requested L2CAP disconnection, that could be caused by 'CPBS' continuously with reply 'ERROR' and PSM internally timeout. 
Just want to confirm the CK behavior, if you tested with PCM, and don't do 'TRANSFER PHONEBOOk', will PCM start to download phonebook via HFP extended AT commands?
Since we currently don't support PBAP and HFP Phonebook AT commands, so basically we don't support phonebook feature.

So, I want to make sure HFP connection dropped if PSM starts to download phonebook via AT commands automatically. If user DOES NOT go into menu 'Go to OPTIONS -> SET PHONE -> TRANSFER PHONEBOOk', and disconnection still happens, this bug might be worth fixing it.

Current v1.1 does not support phonebook feature. So if user tries to download phonebook and it causes disconnection, we might fix in the future version not v1.1.
Flags: needinfo?(shuang) → needinfo?(leo.bugzilla.gecko)
Priority: -- → P1

Comment 8

5 years ago
Leo will follow up with QE engineers to get a waiver here.
blocking-b2g: leo? → -
(Assignee)

Comment 9

5 years ago
This required to add additional reading phone book feature. Bluetooth handsfree needs to access phone book database. I think this would be considered as adding new feature. So it would probably access contacts db directly from gecko.
(Reporter)

Comment 10

5 years ago
Dear Mozilla Team,

I agree with your opinion.
b2g v1.1 does not support PBAP, so PSM carkit request L2CAP disconnection.
I'll close this bug for reason of not supported feature and carkit's request.

Thanks.
Flags: needinfo?(leo.bugzilla.gecko)
Closing per comment #10.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: feature
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.