Support calendar autodetection via draft-daboo-srv-caldav-10

RESOLVED DUPLICATE of bug 306495

Status

defect
RESOLVED DUPLICATE of bug 306495
6 years ago
5 years ago

People

(Reporter: agx, Unassigned)

Tracking

(Depends on 2 bugs)

Dependency tree / graph

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/20100101 Firefox/19.0 Iceweasel/19.0.2
Build ID: 20130309055227

Steps to reproduce:

Lightning should support calendar autodetection as described in 

http://tools.ietf.org/html/draft-daboo-srv-caldav-10

this is supported by at least davical and apple's calendarserver. This would make setting up new accounts as simple as it's in Thunderbird these days. I've started implementing this as an extension.
Reporter

Comment 1

6 years ago
If we don't want to be stuck with the domain name we needs at least the ability to look up SRV records (#14328) but TXT (#545866) is needed too. In fact I was a bit irritated that such generic functionality isn't available or am I missing something?
Depends on: 545866, 14328
Reporter

Comment 2

6 years ago
It seems #735967 tracks the current state of DNS resolution.
Depends on: 735967

Updated

6 years ago
Blocks: 883082
Reporter

Comment 3

6 years ago
To prototype I started with an extension:

https://honk.sigxcpu.org/gitweb/?p=calendar-autoconfig.git;a=summary

Hope to add the CalDAV part soonish.
I'm duping this against bug 306495, where I think most of the work will be done. If we end up only doing part of the work there, we should file followup bugs once its done.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 306495
You need to log in before you can comment on or make changes to this bug.