BMP images with BITMAPSV5HEADER are not always parsed/rendered correctly

RESOLVED DUPLICATE of bug 1214072

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 1214072
5 years ago
2 years ago

People

(Reporter: Téo Mazars, Unassigned)

Tracking

20 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 737261 [details]
32bpp_RGBA_bmpv5_bi_bitfield.bmp

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130401133152

Steps to reproduce:

Open the image attached in this bug report with firefox.

Image description :

- Bitmap using BITMAPV5HEADER
- BI_BITFIELDS compression
- 32 bits per pixel storage
- bitmasks :

RedMask;      : 0xff000000
GreenMask;  : 0x00ff0000
BlueMask;     : 0x0000ff00
AlphaMask;   : 0x000000ff

Additional information :
- Tested with a 64 bit Linux distribution (Fedora 17) with firefox 20.0
- The image is correctly oppened with GIMP, gthumb, eog, ...
- A quick look at src/image/src/BMPFileHeaders.h show that there is no alpha in the bitFields struct.
- Also, in src/image/decoders/nsBMPDecoder.cpp doesn't parse alpha bitfields of bitmap v5.

If I interpret that correctly, it looks like that it's just not implemented.


Actual results:

The image appear blue with a black disc on the center.


Expected results:

The image is black with a transparent disc on the center.
(Reporter)

Comment 1

5 years ago
Created attachment 737270 [details]
resending the attachment

The previous attachement has been deleted. I am not sure why...
(Reporter)

Comment 2

5 years ago
Well I don't know what I did wrong... The file can be found here : https://bug697431.bugzilla-attachments.gnome.org/attachment.cgi?id=240849

Updated

5 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core
Confirmed in 32.0a1 (2014-05-26), Win 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
See Also: → bug 1014810

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1214072
You need to log in before you can comment on or make changes to this bug.