Closed Bug 861712 Opened 6 years ago Closed 6 years ago

crash in mozilla::dom::AudioContext::UnregisterPannerNode

Categories

(Core :: Audio/Video, defect, critical)

All
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 853298

People

(Reporter: azakai, Assigned: padenot)

Details

(Keywords: crash, reproducible)

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-42bec3a2-35ea-45c7-99aa-fde182130415 .
============================================================= 

I can reproduce this crash very reliably by running the emscripten browser tests,

python tests/runner.py browser

The crash happens in a different test each time, I guess one of the web audio tests causes the crash some time after its tab is closed and it is cleaned up.
Keywords: reproducible
Version: unspecified → Trunk
Ah yeah, Context() is probably wrong at that point, or something.
Assignee: nobody → paul
Status: NEW → ASSIGNED
kripken: thanks, I could repro without problems.
Attachment #737415 - Flags: review?(ehsan)
Comment on attachment 737415 [details] [diff] [review]
Nullcheck when unregistering the pannernode. r=

Review of attachment 737415 [details] [diff] [review]:
-----------------------------------------------------------------

r=me I guess, but this fix is already on inbound.

::: content/media/AudioStream.cpp
@@ +65,5 @@
>      // value, the longer stream volume changes will take to become
>      // audible.
>      uint32_t value = Preferences::GetUint(aPref, 100);
>      MutexAutoLock lock(*gAudioPrefsLock);
> +    gCubebLatency = std::min<uint32_t>(std::max<uint32_t>(value, 0), 1000);

Trying to sneak in this change here? ;-)

::: content/media/webaudio/PannerNode.cpp
@@ +181,5 @@
>  PannerNode::~PannerNode()
>  {
> +  if (Context()) {
> +    Context()->UnregisterPannerNode(this);
> +  }

I've already fixed this in my patch to bug 853298, currently on inbound.
Attachment #737415 - Flags: review?(ehsan) → review+
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853298
You need to log in before you can comment on or make changes to this bug.