<textarea> editor just plain "wacky"

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: evildave, Assigned: rubydoo123)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060703

There are several problems with <textarea>, and now I see it's in your "bug
submission form", too.  The field I'm typing this text into, as a matter of
fact, so I'm editing this in 'Notepad' so I can edit it without going insane and
just paste it in.

First, scrolling with mouse, scrolling with arrows, scrolling with page up/down
all appear to all keep different positions.  This drives me nuts.  If you arrow
to the end of the text, it will "wrap" back to the beginning, but if you arrow
to the beginning of the text, it doesn't, so it takes several tries to get the
cursor to the end of the last line.

If you "CUT" text (Ctrl-X), it pads the place where you cut the text from.  This
is horrible if you're used to the way things are edited in, say, every other
Windows editor, including the one you use for email.

While editing more than trivial amounts of text, lines of text seem to
"disappear" at random.  The text magically "reappears" when you tinker with the
scrolling.  This worsens with cuts and pastes.

UNDO and REDO do not work. (Ctrl-Z, Ctrl-Y)

I don't know if <textarea> is attempting to emulate some previous version of
Netscape or not.  If it does, please emulate something else!  I seem to recall I
quit using Netscape navigator because it's editors "sucked".  Perhaps a user
preference to either emulate the behavior of the surrounding operating system's
editable field quirks (wrap the current OS's editable field with whatever your
editble field output is expected to be?), or to do this the horrible way it's
done now.  I can't imagine it's "right" the way it is.



Reproducible: Always
Steps to Reproduce:
1.Go to an HTML page with a multi-line editable field, like '
Description' on this bug submission form.
2. Type more than a trivial amount of text into it and try to edit previous
lines, like you changed your mind about something, or decided to re-arrange the
contents slightly to make it more clear.
3. Be driven completely insane by its little "quirks"

Actual Results:  Eventually, I got the text I wanted, but I had to edit in an
external text editor and paste it in.  The more text I type, the worse it is.

Expected Results:  Bring up Windows 'Notepad'.  Turn on 'word wrap'.  It should
behave *exactly* like that in the windows version of Mozilla because that's
exactly the way people using windows expects it to behave.  Otherwise, it just
**** people off.  You do want them using Mozilla instead of Internet Exploder,
don't you?
I'm using build 2001-06-13-08 here.

The wrapping is bug 82151.  Cut does no padding here, and UNDO/REDO work fine. 
Are they still broken for you in a newer build?

Please file separate bugs on the other issues, one bug per issue.  That will
make it much easier and faster to track them and fix them.

Thanks for using Mozilla and reporting bugs!
(Assignee)

Comment 2

18 years ago
what version are you using? some of the issues you raise have already been 
reported and resolved. If you can upload a more recent version, you should see 
many of the problems fixed, if they are still present, please open a new bug 
report for each issue.

marking as wfm, and awaiting reporter to submit individual bugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 3

18 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.