Closed Bug 861857 Opened 9 years ago Closed 9 years ago

Typeinference: Fault in intersectionEmpty

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- fixed
firefox23 --- fixed

People

(Reporter: h4writer, Assigned: h4writer)

References

Details

(Keywords: regression)

Attachments

(1 file)

Obvious by just reading the code. This was meant to test "this" and "other". Not twice "this". Introduced in 849781. Will have to get uplifted.
Attached patch patchSplinter Review
Assignee: general → hv1989
Blocks: 849781
Attachment #737482 - Flags: review?(jdemooij)
Comment on attachment 737482 [details] [diff] [review]
patch

Review of attachment 737482 [details] [diff] [review]:
-----------------------------------------------------------------

Nice catch.
Attachment #737482 - Flags: review?(jdemooij) → review+
https://hg.mozilla.org/mozilla-central/rev/eb95b49e094c
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Comment on attachment 737482 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 849781

User impact if declined:
For now we haven't hit a bug (I think), but I think it is possible to create a testcase that misbehaves

Testing completed (on m-c, etc.): m-i: 1 day, m-c: 1/2 day

Risk to taking this patch (and alternatives if risky): 
Very low risk. Inlining of functions is now a bit stricter. I.e. that code now uses the general case, instead of the special case.

String or IDL/UUID changes made by this patch:
/
Attachment #737482 - Flags: approval-mozilla-aurora?
Keywords: regression
Comment on attachment 737482 [details] [diff] [review]
patch

low risk uplift of a Fx22 regression .
Attachment #737482 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.