Closed Bug 861885 Opened 7 years ago Closed 6 years ago

Defect - Context menu in youtube is persistent in normal mode after any operation

Categories

(Firefox for Metro Graveyard :: Browser, defect, P3)

x86_64
Windows 8
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: virgil.dicu, Unassigned)

References

Details

Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20130415 Firefox/23.0
http://hg.mozilla.org/mozilla-central/rev/261d6997d1d1

1. Start Firefox Metro
2. Open a video in youtube.com
3. Right click for context menu in youtube video frame.

Actual result:
Context menu is displayed and persistent. It remains displayed after any browser operation.

Found while verifying story Bug 842639 - Story - watch and listen to video and audio.
Summary: Context menu in youtube is persistent → Defect - Context menu in youtube is persistent in normal mode after any operation
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=0
p=2 probably is better to block some context menu bug though.
I looked around for a better story for this to block but there doesn't seem to be one; the only context menu bug is related to styling.
I'm not able to reproduce this.
Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130429 Firefox/23.0
Can still reproduce:
1. Opt in to the html5 trial
2. Visit http://www.youtube.com/watch?v=kkGeOWYOFoA 
3. Right Click - context menu displayed
4. Click/right click outside the video frame or in the video frame in the same tab.

The only way to dismiss the context menu is to move focus to another tab/window.
(In reply to Virgil Dicu [:virgil] [QA] from comment #4)
> Mozilla/5.0 (Windows NT 6.2; rv:23.0) Gecko/20130429 Firefox/23.0
> Can still reproduce:
> 1. Opt in to the html5 trial
> 2. Visit http://www.youtube.com/watch?v=kkGeOWYOFoA 
> 3. Right Click - context menu displayed
> 4. Click/right click outside the video frame or in the video frame in the
> same tab.
> 
> The only way to dismiss the context menu is to move focus to another
> tab/window.

Ah ok, I see this now. I was thinking the context menu stayed visible across tabs.

This appears to be the default behavior for youtube, I can reproduce this on desktop as well with the flash plugin disabled. Don't think this has anything to do with the browser.
(In reply to Jim Mathies [:jimm] from comment #5)
> (In reply to Virgil Dicu [:virgil] [QA] from comment #4)
> This appears to be the default behavior for youtube, I can reproduce this on
> desktop as well with the flash plugin disabled. Don't think this has
> anything to do with the browser.

I can't reproduce this on desktop Nightly, nor in IE metro with html5 enabled. Works well there, like any flash video for me: context menu dismissed when left/right clicking outside of the context menu.

I can only reproduce this issue in nightly Immersive mode, so I'm pretty sure there is still something wrong here.
The steps I'm using on desktop:

1) open a yt video in html5
2) pause and right click to bring up context menu
3) click outside the video anywhere in content, including the yt search text input above the video.

result: context menu remains visible

The only way I'm able to get the menu to hide is by clicking in firefox address bar.

On metro things are similar, clicking in content doesn't remove the menu. Swiping in the flyouts or bringing up the address bar and clicking in the url bar hides the menu.
Nightly screencast: http://www.screencast.com/users/chiciu24/folders/Default/media/825a39e0-67a6-4fc3-83b1-e6fb1baf1af9

Desktop screencast: http://www.screencast.com/users/chiciu24/folders/Default/media/9f1eb5f4-12df-4590-96e7-448fa9027a3e

(In reply to Jim Mathies [:jimm] from comment #7)
> The only way I'm able to get the menu to hide is by clicking in firefox
> address bar.

That's strange. I can't reproduce that on any machine here. Hope the screencasts help.
Thanks for the detailed debugging. Lets see if someone else on the team can reproduce.
Blocks: metrov1it7
No longer blocks: metrov1defect&change
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=0 → feature=defect c=content_features u=metro_firefox_user p=2
Priority: -- → P1
(In reply to Jim Mathies [:jimm] from comment #7)
> The steps I'm using on desktop:
> 
> 1) open a yt video in html5
> 2) pause and right click to bring up context menu
> 3) click outside the video anywhere in content, including the yt search text
> input above the video.
> 
> result: context menu remains visible
> 
> The only way I'm able to get the menu to hide is by clicking in firefox
> address bar.
> 
> On metro things are similar, clicking in content doesn't remove the menu.
> Swiping in the flyouts or bringing up the address bar and clicking in the
> url bar hides the menu.

I tried this in desktop Firefox and the context menu persisted.

Seems like this is a bug in shared code?
Blocks: metrov1defect&change
No longer blocks: metrov1it7
Priority: P1 → --
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=2 → feature=defect c=content_features u=metro_firefox_user p=0
Metro Firefox will depend on HTML5 YouTube more than desktop Firefox which has Flash, but we should still try to get a cross platform solution. 

Jaws, any chance you and look at this?
Priority: -- → P3
Thank for you for the detailed screencast Virgil. I noticed in the Metro screencast that the "plugin is required to view this content" overlay is shown.

Clicking on that, as the video shows, will likely load Flash or some other plugin. Virgil, can you make sure that you don't have Flash installed?

Flash can steal keystrokes and mouse keys if it is enabled, and refocusing out of the window and back will temporarily fix it.
(In reply to Jared Wein [:jaws] from comment #12)
> Thank for you for the detailed screencast Virgil. I noticed in the Metro
> screencast that the "plugin is required to view this content" overlay is
> shown.
> 
> Clicking on that, as the video shows, will likely load Flash or some other
> plugin. Virgil, can you make sure that you don't have Flash installed?

Metro doesn't support any plugins at the moment, so yes, I'm positive - I tried all scenarios: disabled, uninstalled/opt in to html5. The behavior is as described in comment 0. 

The overlay is shown in desktop as well the first time a video is opened in a session.

FTR, not all youtube videos work in html5. I usually test with: http://www.youtube.com/watch?v=kkGeOWYOFoA
Duplicate of this bug: 907026
No longer blocks: metrov2defect&change
Looks like they finally fixed this.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
No longer blocks: metrobacklog, 842639
Whiteboard: feature=defect c=content_features u=metro_firefox_user p=0
You need to log in before you can comment on or make changes to this bug.