Closed Bug 861963 Opened 9 years ago Closed 4 years ago

Integrate test262 test suite

Categories

(Core :: JavaScript Engine, defect)

Other Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 977849

People

(Reporter: jorendorff, Unassigned)

Details

We should run it on the tinderboxen, for two reasons:

1. to make sure we don't regress

We will need a list of expected failures, since we don't pass everything in test262.

2. to give back

I haven't looked into licensing etc. etc., but as we implement new ES6 features, it seems only considerate to donate our tests so other engines can use them.
Assignee: general → nobody
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 977849
You need to log in before you can comment on or make changes to this bug.