Closed Bug 862096 Opened 7 years ago Closed 7 years ago

[B2G] [Inari] [Browser] video playback are stutters while playing if the video controls are visible

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:tef+, b2g18+)

VERIFIED DUPLICATE of bug 863441
1.0.1 Cert2 (21may)
blocking-b2g tef+
Tracking Status
b2g18 + ---

People

(Reporter: ckreinbring, Assigned: sotaro)

References

Details

(Keywords: smoketest, Whiteboard: future dup)

Attachments

(1 file)

Description:
A user that attempts to watch a YouTube video on their Inari device will have the video stop with a green screen almost every time.

Repro Steps:
1) Updated to Inari Build ID: 20130415070202
2) Launch the Browser and navigate to YouTube.com
3) Select a video to play (the longer the better) and begin playing.
4) Observe the video as it plays.

Actual:
At some point in the video playback, the video will prematurely stop and show a green screen.

Expected:
The entire video will play without glitches or freezes.

Environmental Variables:
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/2b44e2c40cc1
Gaia: c79e761bae4d92f329154c64159f4f5c8eb49c9e

Notes:
Repro frequency: 90%
Test Suite Name: Firefox OS Daily Smoketest
UCID: Daily Smoketest
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?pagenumber=1&pagesize=20&sortfield=created_on&sortdirection=desc&filter-id=6073
Q Analysts Test Team Priority: Pri 2
See attached logcat logs for more info.
I didn't seem to have an issue:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/2b44e2c40cc1
Gaia   c79e761bae4d92f329154c64159f4f5c8eb49c9e
BuildID 20130415070202
Version 18.0
Inari

Can you post the links to the videos you used please?
Flags: needinfo?(ckreinbring)
I was able to repro it in Inari commercial RIL 1.0.1
Version: 20130416070200
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/6bac24e14538
Gaia: c883af5ecd0998f78d9aaa4c2337c842e1dbb5a0

The key appears to be having the UI up while the video is playing.  The video appears to be fine if the UI remains hidden.

MONSTER Wild Boar Hunt in Hungary
http://www.youtube.com/watch?v=pAuM8Ks2rRM

Baby Tiger Cub Plays
http://www.youtube.com/watch?v=8wwA4tywdaw

Living Inside the Shell - GitS SAC OST 2
http://www.youtube.com/watch?v=YSj91yopjDg
Flags: needinfo?(ckreinbring)
I do see a slight stutter; I do not see a constant interruption.  I think there's some sort of wifi/network issue at your location
Summary: [B2G] [Inari] [Browser] YouTube videos are constantly interrupted mid-stream → [B2G] [Inari] [Browser] video playback are stutters while playing if the video controls are visible
This might get better with the gralloc changes in bug 862397
Confirmed that it happens also in Firefox OS v1.0.1 on unagi. Nominate to tef+.
blocking-b2g: --- → tef?
Assignee: nobody → sotaro.ikeda.g
blocking-b2g: tef? → leo?
Assignee: sotaro.ikeda.g → nobody
could be that v1.1.0 is also affected, i hit this today on Unagi running v1.1.0 04/22 build

- YouTube video stops with a green screen, unable to reproduce it every time... 

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dfa6bdc5e6da
Gaia   3cdab45a783efadf9b97decf46bd15b83fb91ed8
Build  2013-04-22-070204

(In reply to Sotaro Ikeda [:sotaro] from comment #5)
> Confirmed that it happens also in Firefox OS v1.0.1 on unagi. Nominate to
> tef+.
blocking-b2g: leo? → tef?
tracking-b2g18: --- → +
Bug 865091 blocks the STR of this bug.
Depends on: 865091
If this happens after fixing bug 865091 this should be a blocker
blocking-b2g: tef? → tef+
Target Milestone: --- → 1.0.1 Cert2 (28may)
Once bug 865091 is fixed we'll find an assignee here if still necessary.
865091 is fixed. Is this bug still a problem?
Naoki - we'd like to get this off the list if it isn't reproducing.
Keywords: qawanted
QA Contact: nhirata.bugzilla
Still repros on Inari 1.0.1 commercial RIL, but only about 20% of the time.  It also repros regardless of whether or not the UI is visible.

Build ID: 20130501070201
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/010498e599a7
Gaia: 09046df332cd217cf4fad55c48ce9ce3f14ee5a4
Version #: 18.0
Keywords: qawanted
QA Contact: nhirata.bugzilla
Sotaro told me there are a number of issues affecting video playback here.
Assignee: nobody → sotaro.ikeda.g
Depends on: 863441
Is dupe of bug 863441. By applying temporary fix as in Bug 863441 comment #67, the problem was fixed. A lot of issues are caused by intermittent slow data input.  The temporary fix mitigate the problem by buffering more decoded video frames.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 863441
No longer depends on: 863441
Whiteboard: future dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.