Please remove Pinterest from e.me listing

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Everything.me
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: akeybl, Assigned: ranbena)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: p= [status: need partner decision] [apps watch list])

(Reporter)

Description

5 years ago
Due to bug 860818, we should remove Pinterest from e.me until we get resolution from Pinterest.
(Reporter)

Updated

5 years ago
Assignee: nobody → ran
blocking-b2g: --- → tef+
(Reporter)

Updated

5 years ago
Blocks: 860818

Comment 1

5 years ago
As suggested in 860818 Pinterest is a top-ranked website in launch countries (e.g. Brazil) and so is nba.com and other sites that cause OOM and have been reported as bugs which we were asked to remove from our index.

The action of blacklisting an app for FxOS is technically straight forward, but the content portfolio effects it has on the launch is far beyond technical, it's quite unfitting to not have all of these top sites. 
In addition to that, these sites will crash the Firefox browser on the device as well, so it's enough that a user simply types in the address (which makes sense given the top brands that are affected).

I think the discussion should be about how this can be remedied on a lower level, or we'll end up blacklisting a big chunk of highly ranked and rich web applications.
Whiteboard: p= [status: no solution yet]
Ran any news about this ?
Flags: needinfo?(ran)

Comment 3

5 years ago
Talked with CJ who is a platform team manager, in short term, we don't have solution to remedy it on a low level. We strongly suggest to remove this from e.me for now.
Daniel, can you provide your thoughts on this?

While everyone would like to have Pinterest in E.me by default, it seems not reasonable to do so if it OOM crashed 85% of the time (https://bugzilla.mozilla.org/show_bug.cgi?id=860818#c6).

Once the underlying platform problem is fixed, we can re-enable the site.
Flags: needinfo?(dcoloma)
Whiteboard: p= [status: no solution yet] → p= [status: need partner decision]
Note, there's activity that will improve this in bug 862970 (tef+).

Updated

5 years ago
Whiteboard: p= [status: need partner decision] → p= [status: need partner decision] [apps watch list]

Comment 6

5 years ago
Given it's likely we'll land bug 862970, should we tef- this bug?

Comment 7

5 years ago
Lets tef-, we can reconsider if the other bug fails to deliver.
(In reply to Andreas Gal :gal from comment #7)
> Lets tef-, we can reconsider if the other bug fails to deliver.

Actually, let me put qawanted instead as well. If bug 860818 ends up looking okay with the locked images patch, then we can close this as invalid.
Keywords: qawanted

Updated

5 years ago
QA Contact: jsmith

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Comment 9

5 years ago
to tef? along with 860818
blocking-b2g: tef+ → tef?

Updated

5 years ago
QA Contact: jsmith

Comment 10

5 years ago
Bug 860818 was not fixed with bug 862970. 
Pinterest still crashes if scrolled too quickly using the app, as well as in browser. 
Checked on the master build 

Unagi
Build ID: 20130429031045
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/mozilla-central/rev/05533d50f2f7
Gaia: 153f6805839ccfcd4b1064568377ef26bacf2960
Keywords: qawanted
I said the following on bug 860818:

(From https://bugzilla.mozilla.org/show_bug.cgi?id=860818#c44)
> FWIW, on my unagi running a v1.0.1 build from earlier today (gecko
> fd004d7126, gaia cf2d4136f), I can't reproduce the crash with scrolling in
> either the browser or e.me pinterest.  And I can load m.pinterest.com and
> the browser (or e.me app) doesn't get killed or crash.
I was able to reproduce the original bug on b2g18 on today's build. Let me run a comparison against what Andrew said on 1.01 on partner builds.
Analysis for triage is described over in:

https://bugzilla.mozilla.org/show_bug.cgi?id=860818#c45

Based on what I'm seeing here, bug 862970 doesn't help make the problem better or worse.
Based on bug 867264 I'd suggest we do not block on this one.
Flags: needinfo?(dcoloma)
Whiteboard: p= [status: need partner decision] [apps watch list] → p= [status: need partner decision] [apps watch list][tef-triage]
Not blocking based on comment 14 and comment 11 as well
blocking-b2g: tef? → -
Whiteboard: p= [status: need partner decision] [apps watch list][tef-triage] → p= [status: need partner decision] [apps watch list]
If we aren't blocking on this, then there's no longer value to implement this.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ran)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.