Page encoding persistency over different browser windows

VERIFIED DUPLICATE of bug 65093

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 65093
17 years ago
17 years ago

People

(Reporter: doctor__j, Assigned: Shanjian Li)

Tracking

({intl})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.1+) Gecko/20010615
BuildID: 2001061309

Reproducible: Always
Steps to Reproduce:
1. Load http://www.yahoo.co.jp/ into browser.
2. Verify that the page encoding is set to "Japanese EUC-JP"
3. Open a new browser window.
4. Verify that the page encoding of the _new_ browser window is set to "Western
ISO-8859-1".
5. Load http://www.mozilla.org/ in the _new_ browser window.
6. The page encoding changed to "Japanese EUC-JP".

Expected Results: Page encoding of _new+ browser window is set to "Western
ISO-8859-1", regardless of the encoding applied on the previous browser window.

Updated

17 years ago
QA Contact: andreasb → ylong

Updated

17 years ago
Keywords: intl

Comment 1

17 years ago
I do not see this with NS6.1 PR1 win32.
ylong, could you try the trunk build?

Comment 2

17 years ago
I can reproduce this on both N6.1PR1 and 06-18 trunk build / Win2k-CN and 
Linux6.2-RH-Ja.  Change platform to All.
OS: Windows 98 → All
Hardware: PC → All

Comment 3

17 years ago
I still cannot reproduce.
ylong, what was your default page when you tested this?

Comment 4

17 years ago
OK, here is my steps to repro:
1. Create a new Profile and launch the browser.
2. The default page is: http://home.netscape.com
3. Load http://yahoo.co.jp, you will see the charset set to EUC-JP which is correct for this page.
4. File | New Navigator Window, open a new window, and the default page is:
http://home.netscape.com and charset set to Western(iso-8859-1)
5. Type: http://www.mozilla.org in URL bar.

Then check the charset now is marked as: EUC-JP.
I got same result on both Win2k-CN and Linux RH6.2-Ja.
 

Comment 5

17 years ago
I cannot reproduce this with my win 6/18 trunk build on winme
What is your setting of auto detect?

Comment 6

17 years ago
mark as future
Target Milestone: --- → Future

Comment 7

17 years ago
Reassign to shanjian.
Assignee: nhotta → shanjian
(Assignee)

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 65093 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

17 years ago
Mark as verified.  Please re-open it if you are disagree.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.